Ajouter une condition à une formule [Résolu]

Signaler
Messages postés
146
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
25 août 2020
-
Messages postés
146
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
25 août 2020
-
Bonjour les amis,
Je travaille sur un tableau excel dans lequel :
- le produit1 est consommé chaque mercredi de la semaine
- le produit2 est consommé chaque lundi et jeudi de la semaine
l'huile est consommée en parallèle avec les deux produits ( lundi;mercredi;jeudi)
je veux ajouter une condition dans les cellules F8:F37 pour que si le stock de l'un des deux produits 1 et 2 est nul alors la consommation de l’huile relative a ce produit soit aussi égale à 0
vous trouvez d'autres details dans le fichier joint et merci.
https://www.cjoint.com/c/JHiihMMeWEB


Configuration: Windows / Chrome 84.0.4147.105

7 réponses

Messages postés
19728
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
26 septembre 2020
5 006
Bonjour,

Dans la formule consom de la colonne F :
=SI(OU(A8="lundi";A8="mercredi";A8="jeudi")=VRAI;$F$1;0)

il te faut remplacer $F$1 par la nouvelle condition que tu veux ajouter, à savoir :
(SI(OU(M8=0;V8=0)=VRAI;0;$F$1))

avec M8 et V8 les cases indiquant le stock des produits 1 et 2

Cela donne en final:
=SI(OU(A8="lundi";A8="mercredi";A8="jeudi")=VRAI;(SI(OU(M8=0;V8=0)=VRAI;0;$F$1));0)

Il te reste plus qu'à recopier la formule dans toutes les cellules de la colonne F

Ritchi
Messages postés
2749
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
24 septembre 2020
372
Bonjour à tous,

Une approche :
A mon avis il manque une donnée pour répondre a la question telle qu'elle est posée:
https://www.cjoint.com/c/JHii5mvn6md


Crdlmt
Messages postés
146
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
25 août 2020
3
oui consommation individuelle
Messages postés
5508
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
17 septembre 2020
487
Bonjour

Une idée dans le fichier modifié, Si j'ai bien compris

https://www.cjoint.com/c/JHijjbUA62e
Messages postés
5508
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
17 septembre 2020
487
Bonjour Ritchi

Colonne U

=SI(V9<$U$1;0;SI(OU(A10="lundi";A10="jeudi")=VRAI;$U$1;0))

Colonne C

=SI(M11<$L$1;0;SI(A12="mercredi";$L$1;0))

Colonne F

=SI(U10>0;$F$1;SI(L10>0;$F$1;0))
Messages postés
146
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
25 août 2020
3
Merci Ritchi pour votre formule intéressante
mais dans l'exemple a partir du 13 aout il y a encore du stock pour le produit1 je veux que la cosommation de l'huile reste normale pour les jours relatifs au produit1
Messages postés
19728
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
26 septembre 2020
5 006
Bonjour,

Une remarque générale:
Il vaut mieux copier dans cette discussion les formules Excel que vous proposez car dans quelques jours/semaines/mois les fichiers Excel que vous avez déposés sur le site cijoint ne seront plus accessibles.
Cela rendra impossible aux prochains visiteurs de voir les solutions que vous avez proposées

Ritchi
Messages postés
146
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
25 août 2020
3
Merci les amis grâce à vous c'est résolu