Carte wifi connectée a la freebox, mais pas d'acces internet. [Résolu]

Signaler
-
Messages postés
35852
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
28 novembre 2020
-
Bonjour a tous !
Voici un petit souci qui, je l'espere a une solution toute bete.
Apres avoir réparé un vieux pavilion dv6700, j'installe mint 20 comme sur nombre de machines auparavant.
Lors de l'install, linux ne detecte pas de carte wifi, donc pas d'internet.
Pas grave me dis-je, apres l'install, je branche un dongle wifi, tout fonctionne et mint me trouve meme le pilote pour la carte wifi, l'installe, je suis content.
Mais en fait, malheureusement, apres association a ma freebox, network manager me montre bien connecté a la freebox, avec un bon signal, mais impossible de lancer des mises a jour, bi d'ouvrir une page, bref aucun acces....
C'est bien dommage tout ca, un coup de pouce me serait bien utile.
Merci d'avance.

Pour info:
-linux mint 20 cinnamon 4.6.6 avec toutes les dernières maj
-noyau 5.4.0-42
-freebox mini 4k
-carte wifi: broadcom and subsidiaries BCM4321 802.11a/b/g/n
-driver: bcmwl-kernel-source
version 6.30.223.271+bdcom-0ubuntu5
Broadcom 802.11 Linux STA wireless driver source


Configuration: Android / Chrome 84.0.4147.89

2 réponses

Messages postés
35852
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
28 novembre 2020
5 684
Salut,

L'adresse est fournie via DHCP ou tu es en IP fixe ?
Que te renvoie la commande (le nom de l'interface (wlp3s0) est à adapter en fonction) :
ip a show dev wlp3s0


Que te renvoient les commandes suivantes (en wifi uniquement) :
ping 145.131.132.76
ping startpage.com


Messages postés
8
Date d'inscription
mardi 28 juillet 2020
Statut
Membre
Dernière intervention
29 juillet 2020

Salut a toi et merci de ta réponse.

Alors quelques précisions:
Depuis mon post, la carte ne veut plus se connecter a la box, elle la reconnait bien mais ne se connecte pas.
Via mon smartphone en mode partage de connexion, elle se connecte parfaitement et rapidement, mais toujours pas d'acces internet.

Pour les réponses:
Mon adresse est en dhcp que ce soit en ipv4 ou ipv6

Pour le reste:




Pour le ping startpage.com le terminal me dit Nom ou service inconnu...

En espérant que cela t'aide a m'aider ????

Bonne soirée
Messages postés
35852
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
28 novembre 2020
5 684 >
Messages postés
8
Date d'inscription
mardi 28 juillet 2020
Statut
Membre
Dernière intervention
29 juillet 2020

C'est quoi qui ne marche pas alors ???
Messages postés
8
Date d'inscription
mardi 28 juillet 2020
Statut
Membre
Dernière intervention
29 juillet 2020
>
Messages postés
35852
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
28 novembre 2020

C'est la carte wifi intégrée au pc portable qui ne fonctionne pas:
-reconnait la freebox et capte son signal mais ne se connecte pas a la freebox
-se connecte a mon smartphone (qui partage sa connexion via wifi) mais n'offre pas d'acces a internet.

Le seul moyen de connecter ce pc portable pour l'instant c'est avec une vieille clé wifi qui trainait dans mes archives.


EDIT apres manipulations:

Bon alors apres install du pilote dédié.
-la carte wifi intégrée reconnait la box et s'y connecte, mais toujours pas d'acces internet...
-avec rfkill a priori rien n'est bloqué, j'ai tout de meme effectué un unlock all pour la forme.
-pour l'EFI, c'est vite vu, c'est un vieux trombon donc pas d'EFI ni secure boot dans le bios plus que minimaliste :-D
Messages postés
35852
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
28 novembre 2020
5 684 >
Messages postés
8
Date d'inscription
mardi 28 juillet 2020
Statut
Membre
Dernière intervention
29 juillet 2020

En même temps, sur la page consacrée aux cartes Broadcom, concernant la tienne il est stipulé : "Prise en charge partielle" ;-\
Messages postés
8
Date d'inscription
mardi 28 juillet 2020
Statut
Membre
Dernière intervention
29 juillet 2020
>
Messages postés
35852
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
28 novembre 2020

Oui c'est bien ce que j'ai vu.
C'est ultra partiel.
Détection de la box et puis c'est tout lol.
Eh bien tu sais quoi je vais arreter de t'embeter la car je sens la chose mal partie.

Je vais tenter le coup sur une install de windows sur un autre disque dur et sinon ca sera mon petit Mint avec une mini clé wifi histoire que ca fasse moins tache ????. (Heureusement que les vieux portables ont plus de ports usb qu'aujourd'hui ????

Je te remercie beaucoup en tout cas.
Messages postés
35852
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
28 novembre 2020
5 684 >
Messages postés
8
Date d'inscription
mardi 28 juillet 2020
Statut
Membre
Dernière intervention
29 juillet 2020

De rien, bon courage pour la suite ;-)