Formule excel [Résolu]

Signaler
-
Messages postés
38500
Date d'inscription
mercredi 11 avril 2007
Statut
Modérateur
Dernière intervention
2 juillet 2020
-
Bonjour,

J'aurai besoin d'aide..

J'ai un tableau excel ci-joint (que j'ai raccourci car il le fichier est trop lourd).
Chaque client a différents animaux : soit des ovins/caprins, soit des bovins, ou les deux.
Je voudrais créer une formule dans "Espèce" qui prenne en compte la chose suivante :
- Si un client à que des ovins/caprins, mettre dans "Espèce" = Ovins/Caprins, si il n'a que des "Bovins" = mettre "Bovins", par contre si il y a des Ovins/Caprins et des Bovins, mettre = MIXTE.

Un grand merci pour votre retour.. ☺☺

3 réponses

Messages postés
604
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
3 juillet 2020
53
Bonjour,
en C2, à tirer vers le bas :

=SI($D2="Ovins/Caprins";$D2;SI($D2="Bovins";$D2;SI($D2="Ovins/Caprins/Bovins";"MIXTE";"")))
Messages postés
604
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
3 juillet 2020
53
Désolé, je viens de me rendre compte que cette formule, à ne pas prendre compte, ne peut fonctionner !

ça aurait pu s'il y avait la possibilité de mettre Ovins/Caprins/Bovins dans une cellule ;)
Messages postés
25155
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 juin 2020
5 343
Bonjour
avec un image c'est un peu juste pour être pré
cis
essayez avec, en, commençant en C2
=SI(ET(NB.SI.ENS(B:B;B2;D:D;"ovins/caprins");"NB.SI.ENSEMBLE(BB;B2;D:D;"bovins"));"mixte";SI(NB.SI.ENS(B:B;B2;D:D;"ovins/caprins");"ovins/caprins";"bovins"))
et si vous ne voulez voir apparaître cette formule que sur la 1° ligne ou apparaît le code client, complétez avec
=SI(OU(B2="";NB.SI($B$2:B2;B2)>1);"";SI(ET(NB.SI.ENS(B:B;B2;D:D;"ovins/caprins");"NB.SI.ENSEMBLE(BB;D2;"bovins"));"mixte";SI(NB.SI.ENS(B:B;B2;D:D;"ovins/caprins");"ovins/caprins";"bovins")))
attention aux signes
revenez si ça ne convient pas, mais si possible déposez votre modèle, par exemple ici:
http://mon-partage".fr
et revenez coller le lien créé sur le site

Utilisateur anonyme
Merci beaucoup pour votre retour, mais la formule ne marche pas.. Quand je fais un copier/coller elle reste telle que.

Mon fichier ne veut pas se mettre sur "mon-partage"..
Messages postés
604
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
3 juillet 2020
53 > Utilisateur anonyme
Messages postés
25155
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 juin 2020
5 343
Désolé, mea-culpa, j'ai fait un peu n'importe quoi, emporté par l'élan
essayez avec:
=SI(ET(NB.SI.ENS(B:B;B2;D:D;"ovins/caprins");NB.SI.ENS(B:B;B2;D:D;"bovins"));"mixte";SI(NB.SI.ENS(B:B;B2;D:D;"ovins/caprins");"ovins/caprins";"bovins"))
(entrée testée et valmidée par Excel)
ou en version éliminatoire:
=SI(OU(B2="";NB.SI($B$2:B2;B2)>1);"";SI(ET(NB.SI.ENS(B:B;B2;D:D;"ovins/caprins");NB.SI.ENS(B:B;B2;D:D;"bovins"));"mixte";SI(NB.SI.ENS(B:B;B2;D:D;"ovins/caprins");"ovins/caprins";"bovins")))
crdlmnt
Utilisateur anonyme
Super ☺☺. Merci beaucoup.
Messages postés
38500
Date d'inscription
mercredi 11 avril 2007
Statut
Modérateur
Dernière intervention
2 juillet 2020
7 801 > Utilisateur anonyme