Contenu d'une cellule en fonction d'une autre cellule au format Date [Résolu/Fermé]

Signaler
Messages postés
22
Date d'inscription
vendredi 26 août 2016
Statut
Membre
Dernière intervention
10 mai 2020
-
Messages postés
22
Date d'inscription
vendredi 26 août 2016
Statut
Membre
Dernière intervention
10 mai 2020
-
Bonjour,
j'ai un fichier avec une colonne correspondant à une date d'expiration...
EN fonction de la date du jour, le remplissage est rouge si expiré, orange si expiration dans moins de 3 moins et jaune si expiration dans moins de 6 mois et vert si en curs (donc au delà de 6 mois).
Ce remplissage est obtenu par mise ne forme conditionnelle.
Je souhaiterais avoir une colonne qui affiche le texte en toute lettre.
Je m'explique
Date reference AUJ 10 MAI 2020
Si en A4, j'ai Date Expiration 07/04/2020, la colonne est en rouge et la colonne suivante devra afficher "Expiré" en rouge et gras
Je joins un fichier avec le format spécifique du texte à afficher
https://www.cjoint.com/c/JEkcglaza4l

et j'ai essayé la formule suivante :

=SI(AUJOURDHUI()>$A4;"Expiré";SI(ET($A4>AUJOURDHUI();$A4=AUJOURDHUI()>MOIS.DECALER($A4;-6));"Expire dans 6 mois";SI(ET($A4>AUJOURDHUI();$A4=AUJOURDHUI()>MOIS.DECALER($A4;-3));"Expire dans 3 mois";SI($A4>AUJOURDHUI();"En cours";)))
mais je n'obtiens pas le résultat.
J'utilise la version Excel365: j'ai testé Si.conditions sans succès.
Mais la saisie se fera sur Excel2013 ou Excel 2017.
Merci pour toute aide
Mwasikitoko

4 réponses

Messages postés
3273
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 juin 2021
923
Non, dans l'état actuel des mes connaissances sur excel, je ne crois pas qu'il soit possible de colorer par MFC une partie des mots dans la même cellule.

Il va falloir se contenter de formater la police ou le remplissage de la cellule ou les deux en même temps comme dans la colonne A.

A moins qu'avec une macro "?" mais là je ne suis pas compétent en la matière.

Cordialement
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
3273
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 juin 2021
923
Bonjours

La bonne forme à appliquer est

=SI(A4="";"";SI(AUJOURDHUI()>A4;"Expiré";SI(AUJOURDHUI()>MOIS.DECALER(A4;-3);"Expire dans 3 mois";SI(AUJOURDHUI()>MOIS.DECALER(A4;-6);"Expire dans 6 mois";"En Cours"))))

Pour les MFC la formule pour la colonne B sélectionnée est (pour les 4 cas)

=B4="le mot ou groupe de mots"

Cordialement
Messages postés
22
Date d'inscription
vendredi 26 août 2016
Statut
Membre
Dernière intervention
10 mai 2020

Merci PapyLuc51
J'ai compris le raisonnement des conditions SI...
Ben oui c'est ça ...mais tellement pas évident à formuler...
Par contre, je n'ai pas saisi la mise en forme conditionnel sur la colonne B.
Pour "Expiré" ou "En cours " pas de problème car la mise en forme portera sur la cellule mais comment formater "Expire" & " 3 mois" dans "Expire dans 3 mois"
Merci
Messages postés
22
Date d'inscription
vendredi 26 août 2016
Statut
Membre
Dernière intervention
10 mai 2020

Merci PapyLuc51
En tout cas la formule proposée répond entièrement à mes attentes
Bonne journée
Mwasikitoko