Recherche avancée [Résolu]

Signaler
Messages postés
731
Date d'inscription
dimanche 4 janvier 2009
Statut
Membre
Dernière intervention
30 juin 2020
-
Messages postés
731
Date d'inscription
dimanche 4 janvier 2009
Statut
Membre
Dernière intervention
30 juin 2020
-
Bonjour,

Je recherche une formule avancée, éventuellement meilleure que des SI imbriqués.

J'ai une table de valeurs, avec plus de 50 références (mais je vais simplifier):

MIN I MAX I Taux
0 I 5 I 1
6 I 10 I 2
11 I 15 I 3
etc.

Sur une autre table, j'ai un valeur. Il faut chercher le taux en fonction la plage de valeurs (MIN - MAX) ou la valeur se situe.

Merci.

6 réponses

Messages postés
836
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
9 juillet 2020
166
Bonjour,

Un p’tit classeur avec 10/15 données serait mieux pour régler le soucis

Allez dans https://www.cjoint.com/
Cliquez sur "PARCOURIR" pour sélectionner le classeur
Clic le bouton "CREER LE LIEN"
Clic droit quand le lien est créé "COPIER LE LIEN"
Sur le post Clic droit "Coller".

ou dans https://mon-partage.fr/
Messages postés
2681
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 juillet 2020
681
Bonjour

En attendant le fichier demandé par M-12 (salutations)

Le tableau min / max /taux sur les colonnes A B C

La valeur à chercher en D2

en E2 cette formule

=RECHERCHEV(D2;A:C;3;1)

Cordialement
Messages postés
28957
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
15 juillet 2020
2 617
Bonjour,

Si tes colonnes sont en A B C
La recherche peut alors se faire comme ceci:


=INDEX(A1:C4;EQUIV(G1&G2;A1:A4&B1:B4;0);3)

Valeur min cherchée : G1
Valeur maxcherchée : G2

Colonnes de recherches
Min : A1:A4
Max : B1:B4;

Résultat en colonne C


NB: Formule Matricielle à valider par CTRL+MAJ+ENTRER


Messages postés
836
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
9 juillet 2020
166
Messages postés
731
Date d'inscription
dimanche 4 janvier 2009
Statut
Membre
Dernière intervention
30 juin 2020
29
Merci, mais il n'existerait pas une manière d'éviter les SI imbriqué ?
J'ai simplifié l'exemple mais imagine avec un table (avec les Min et Max) avec plus de 50 références...

Merci
Messages postés
2681
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 juillet 2020
681
Re:

Avec ma formule ça fonctionne très bien

https://www.cjoint.com/c/JDwiN32Y4W5

Cordialement
Messages postés
731
Date d'inscription
dimanche 4 janvier 2009
Statut
Membre
Dernière intervention
30 juin 2020
29
C'est exactement ça !
Merci beaucoup !
Messages postés
731
Date d'inscription
dimanche 4 janvier 2009
Statut
Membre
Dernière intervention
30 juin 2020
29
Merci à tous,

On s'approche mais je ne crois pas que cela résolve mon problème...

Voilà le CJOINT:
https://www.cjoint.com/c/JDwiyRc0Yyg

+ copies d'écran:
Il faut que les valeurs dans les cellules en jaunes soient données automatiquement...