Macro afficher un message [Résolu]

Signaler
Messages postés
67
Date d'inscription
lundi 12 novembre 2018
Statut
Membre
Dernière intervention
6 avril 2020
-
Messages postés
67
Date d'inscription
lundi 12 novembre 2018
Statut
Membre
Dernière intervention
6 avril 2020
-
Bonjour,

j'ai un fichier contenant une feuille par jour (fichier qui contiendra les 12 mois de l'année 2020)
les feuille sont nommées au format jj-mm-aaaa
sur chaque feuille la plage J42:J47 contiendront un croix ou resteront vide, les plages H50:H55 et I50:55 prennent les valeurs 0 ou 1
je veux par exemple, en activant une feuille, que si J42 contient un croix et H50 contient 0 alors un message s'affiche:" réclamation non traitée"
et si J42 contient un croix , H50 contient 1 et I50 contient 0 un message s'affiche "veuillez contacter le F/ S-T par téléphone"
J43 avec H51 et I51 ainsi de suite
comme présentée sur la capture ci jointe
https://mon-partage.fr/f/TUEoODFq/
si quelqu'un pourra m'aider je serais très reconnaissante
merci par avance
bien cordialement




Configuration: Windows / Chrome 80.0.3987.149

2 réponses

Messages postés
12397
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
15 juillet 2020
1 925
Bonjour

Pas besoin de macro

Une formule dans la cellule de ton choix :
=SI(J42="";""SI(H50=0;" réclamation non traitée";SI(I50=0; "veuillez contacter le F/ S-T par téléphone" ,"")))

Cdlmnt
Via
Messages postés
67
Date d'inscription
lundi 12 novembre 2018
Statut
Membre
Dernière intervention
6 avril 2020
1
Bonjour,
merci de votre retour!
le problème c'est que le fichier contient 90 feuilles jusqu'à maintenant...
Messages postés
12397
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
15 juillet 2020
1 925
Si toutes les feuilles sont strictement identiques tu les sélectionnes toutes et tu rentres les formules sur la1ere feuille elle sera rentrée automatiquement dans les autres
Messages postés
67
Date d'inscription
lundi 12 novembre 2018
Statut
Membre
Dernière intervention
6 avril 2020
1
Re,
j'ignorais ceci !
merci beaucoup via55!!