#N/A sur index equiv [Résolu]

Signaler
Messages postés
2095
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
31 octobre 2020
-
Messages postés
2095
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
31 octobre 2020
-
Bonjour
Je n'arrive pas à trouver mon erreur
dans ma cellule résultat j'ai #N/A

=SI('Liste chat'!H2="";"";INDEX('Liste chat'!A2:Y1009;EQUIV(Modele!F1;'Liste chat'!H2:H1009;0);8))
Merci pour votre aide
Cordialement

2 réponses

Messages postés
25466
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
5 566
Bonjour
sin la formule renvoi #N/A c'est que Modele!F1 n'existe pas dans le champ 'Liste chat'!H2:H1009
(soit parce qu'il n'y est pas, soit parce qu'il est sous un format différent
mais en aparté ce qui est curieux:
votre formule va chercher dans la colonne H une valeur pour ressortir la valeur de la 8° colonne du champ AY c'est à dire.. la colonne H???
A quoi cela peut-il bien, servir?
à vous lire
crdlmnt

Messages postés
8221
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
31 octobre 2020
1 500
Bonjour,

#N/A n'est pas à proprement dit une erreur mais plutôt une information qui signifie "J'ai pas trouvé".

Quand on sait ce que ça veut dire, on se rend compte qu'il est très souvent plus judicieux de les laisser que de les masquer (par exemple avec un SIERREUR).

D'ailleurs c'est les seul intérêt de ta formule : détecter l'absence de modèle!F1 dans Liste chat'!H2:H1009
sinon il aurait suffit d'écrire :
=SI('Liste chat'!H2="";"";Modele!F1)


Cordialement
Patrice

Personne ne peut détenir tout le savoir, c'est pour ça qu'on le partage.
Messages postés
2095
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
31 octobre 2020
344
Re bonjour

J'ai trouvé mon erreur
=INDEX('Liste chat'!H2:H1009;EQUIV(Modele!F1;'Liste chat'!A2:A1009;0))
Cordialement