Formule excel pour créer des tranches [Résolu]

Signaler
Messages postés
151
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 septembre 2020
-
Messages postés
2154
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
21 octobre 2020
-
Bonjour,
Heureusement que vous êtes là en ce moment difficile.
Je télétravaille et aucun collègue à promiximité pour me dépanner.... peut-être aller vous m'aider.
Je n'arrive pas à faire fonctionner la formule me permettant de définir une tranche en fonction d'un montant. Pas moyen.
J'ai une colonne avec des montants, et j'ai créé ma référence de tranche avec en colonne A le montant et en face en colonne B, j'ai nommé la tranche.

Puis en formule, j'ai écrit "=recherchev(la cellule montant);de Axxx à Bxxxx (que j'ai figé);2;1)

Résultat = que des #N/A ou un résultat non conforme, à savoir que j'ai des montants positifs et négatifs.

Avez vous une solution ?

Merci beaucoup.

Zara70

5 réponses

Messages postés
17293
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
24 octobre 2020
4 303
Bonjour,

#N/A est le message d'erreur de ta formule mais pour t'aider il faut nous donner plus de détail, dans l'idéal serait de créer un exemple de fichier de deux ou trois exemples et nous le poster

pour joindre ton fichier
1) Tu vas dans https://www.cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers

dans le même style tu as https://mon-partage.fr/
Messages postés
5524
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
21 octobre 2020
500
Bonjour Zara70

la colonne A est-elle triée en ordre croissant ?
Bonjour,
Vous pourriez voir ce petit exemple :
https://cjoint.com/c/JCuk0R63lRN
Si cela peut s'appliquer à votre cas.
Cordialement.
Messages postés
17293
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
24 octobre 2020
4 303
Re,

essaye comme cela

=SIERREUR(RECHERCHEV(I8;$A$6:$B20;2;0);"")
Messages postés
2154
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
21 octobre 2020
860
Bonjour
une piste avec des nombres négatifs


=SI(A2>=0;RECHERCHEV(A2;$E$2:$F$9;2;-1);RECHERCHEV(A2;$G$2:$H$5;2;-1))