Automatiser un scoring [Résolu/Fermé]

Signaler
Messages postés
114
Date d'inscription
samedi 29 juin 2013
Statut
Membre
Dernière intervention
1 juin 2021
-
Messages postés
3272
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 juin 2021
-
Bonjour,
Je travaille dans une animalerie et nous notons le poids des animaux tous les jours.

Nous calculons ensuite un pourcentage de perte (ou gain) de poids tous les jours (automatisé sur Excel).

En cas de perte de poids, nous devons donner un score selon une grille établie.

Si l'animal perd moins de 1% de son poids => score = 0
Si l'animal perd entre 1 et 5% de son poids => score = 1
Si l'animal perd entre 5 et 10% de son poids => score = 2
Si l'animal perd entre 10 et 15% de son poids => score = 3
Si l'animal perd plus de 15% de son poids => score = 4

Je possède une feuille "% de perte" dans Excel avec les poids et le pourcentage de perte attribué à chaque animale. Et sur une autre feuille Excel "Score clinique" sont présent les scores de chaque animale.

Je n'arrive pas à créer un système automatique pour convertir le pourcentage de perte de poids (déjà calculé) en score allant de 0 à 4.
Exemple : animal 1 à perdu 7,5% de son poids -> transforme automatiquement le 7,5% en score de 2

Pouvez-vous m'aider ? Quelle fonction utiliser ?

Merci !

PS : le score 1 s'arrête avant les 5% (donc 4,999999999%) et le score 2 commence à 5%, ainsi de suite pour les autres. (il est généralement très rare d'avoir un pourcentage pile à 5% précis)

8 réponses

Messages postés
3272
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 juin 2021
923
J'ai tenté cette formule

=SI(A2<>"";SI(A2>=0;0;RECHERCHEV(ABS(A2);T_Score;2;1));"")

ce qui marque 0 quand le pourcentage est positif, et donne le bon score quand il est négatif.

Cordialement
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
114
Date d'inscription
samedi 29 juin 2013
Statut
Membre
Dernière intervention
1 juin 2021
5
En effet, ça fonctionne !!

C'est super !

Merci beaucoup !!
Messages postés
16477
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
10 juin 2021
3 189
=(B2<0)*(EQUIV(ABS(B2)*100);{0;1;5;10;15};1)-1)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
114
Date d'inscription
samedi 29 juin 2013
Statut
Membre
Dernière intervention
1 juin 2021
5
avec cette formule Excel m'envoie le message d'erreur : "vous avez entrée un nombre insuffisant d'argument pour cette fonction"
Messages postés
3272
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 juin 2021
923 >
Messages postés
114
Date d'inscription
samedi 29 juin 2013
Statut
Membre
Dernière intervention
1 juin 2021

Bonjour à vous deux,

J'ai essayé cette formule et ça a l'air de fonctionner ; il fallait enlever la multiplication par 100.

Avec le pourcentage au format nombre sans % en A2

=(A2<0)*(EQUIV(ABS(A2);{0;1;5;10;15};1)-1)

Avec le format en pourcentage en A2 mettre ABS(A2)*100 entre parenthèses

=(A2<0)*(EQUIV((ABS(A2)*100);{0;1;5;10;15};1)-1)

Cordialement
Messages postés
3272
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 juin 2021
923
Bonjour

un exemple avec une rechercheV

https://www.cjoint.com/c/JBznXuTkHtP

Cordialement
Messages postés
16477
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
10 juin 2021
3 189
Bonjour

cellule B2 au format "pourcentage"

=EQUIV(B2*100;{0;1;5;10;15};1)-1
Messages postés
114
Date d'inscription
samedi 29 juin 2013
Statut
Membre
Dernière intervention
1 juin 2021
5
Bonjour,

Merci pour vos réponses !

Les deux méthodes fonctionnent, merci ! je ne connaissais pas ces calculs ...

En revanche, mes pourcentages de poids sont exprimés en positifs (lors d'un gain de poids) et en négatif (lors d'une perte de poids).

J'ai placé un signe moins devant le B2, dans la formule de Michel_m et ça fonctionne :
=EQUIV(-B2*100;{0;1;5;10;15};1)-1

Pour la méthode de Papyluc51, il faut mettre un moins devant le deuxième A2 des formules:
=SI(A2<>"";RECHERCHEV(-A2;T_Score;2;1);"")

En revanche, dès qu'un pourcentage est positif, cela me met un N/A. cela semble logique mais comment faire pour qu'il indique 0 pour tout pourcentage supérieur à 0 ? (non négatif?)

Merci !
Messages postés
3272
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 juin 2021
923
Est-ce la même grille de scoring pour les négatifs (0,-1,-5,-10,-15) ???
Messages postés
16477
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
10 juin 2021
3 189
Atout hazard essaie en metttant la valeur absolue dans rechercheV de mon ami Papyluc; je n'ai pas vérifié...

ABS(A2) au lieu de A2
Messages postés
3272
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 juin 2021
923
salutations michel_m, c'est exactement à ça que je pensais.

J'ai essayé c'est bon

=SI(A2<>"";RECHERCHEV(ABS(A2);T_Score;2;1);"")

Cordialement
Messages postés
114
Date d'inscription
samedi 29 juin 2013
Statut
Membre
Dernière intervention
1 juin 2021
5
J'avais modifié ma réponse avec la solution, mais vous êtes trop réactif =D
donc je reposte ici pour être sûr qu'il soit vu :

J'ai placé un signe moins devant le B2, dans la formule de Michel_m et ça fonctionne :
=EQUIV(-B2*100;{0;1;5;10;15};1)-1

Pour la méthode de Papyluc51, il faut mettre un moins devant le deuxième A2 de la formule:
=SI(A2<>"";RECHERCHEV(-A2;T_Score;2;1);"")

En revanche, dès qu'un pourcentage est positif, cela me met un N/A. cela semble logique mais comment faire pour qu'il indique 0 pour tout pourcentage supérieur à 0 ? (non négatif?)

En résumé :
Pourcentage positif ou supérieur à -1% => score de 0
Pourcentage entre -1 et -5% => score = 1
Pourcentage entre -5 et -10% => score = 2
Pourcentage entre -10 et -15% => score = 3
Pourcentage inférieure à -15% => score = 4

Merci !
Messages postés
3272
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 juin 2021
923
Voir mon commentaire 6

=SI(A2<>"";RECHERCHEV(ABS(A2);T_Score;2;1);"")

Cordialement
Messages postés
16477
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
10 juin 2021
3 189 >
Messages postés
3272
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 juin 2021

Lu et approuvé ! ;o)

Cordialement
Messages postés
114
Date d'inscription
samedi 29 juin 2013
Statut
Membre
Dernière intervention
1 juin 2021
5 >
Messages postés
3272
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
11 juin 2021

ça fonctionne pour le négatif, en revanche, lorsque le pourcentage est positif (à 7% ou 17%) par exemple, ça ne me met pas zéro, mais ça continue de compter.
En gros les scores fonctionnent pour le négatif et positif mais il me faudrait un score de zéro quand le pourcentage est positif ... =/