Fonction SI avec un plage de données renvoie "#VALEUR"

[Résolu/Fermé]
Signaler
Messages postés
78
Date d'inscription
samedi 14 février 2015
Statut
Membre
Dernière intervention
12 février 2020
-
Messages postés
78
Date d'inscription
samedi 14 février 2015
Statut
Membre
Dernière intervention
12 février 2020
-
bonjour,

j'ai vraiment besoin d'aide.

J'ai un fichier excel qui représente un planning et sur les colonnes de gauche un "bilan".

les données pour un personnel sont sur 2 lignes:

=> la 1ère : la catégorie du poste (J(AG2), F°, S2) Ligne 6 (C6:AD6)
=> la 2è : le poste occupé (R1 P1, Sale1, Gy1) Ligne 7 (C7:AD7)

La formule doit me compter le poste occupé uniquement si la catégorie correspond à J.

Donc c'est c'est censé faire : =SI(C6:AD6=AG2;NB.SI($C7:$AD7;AG$4);o)

Je ne souhaite pas utiliser des formules matricielles dans le sens où à chaque modification il faut les réactiver.

je ne peux malheureusement pas vous envoyer mon fichier, ma boîte bloque l'accès...


https://mon-partage.fr/f/jPyV9JUv/

3 réponses

Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 066
Bonjour
sans trop chercher à comprendre essayez avec:
=SOMMEPROD(($C6:$AD6=AG$2)*($C7:$AD7=AG$4))
mais si ça e va pas il; faudra nous en dire plus .
crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
78
Date d'inscription
samedi 14 février 2015
Statut
Membre
Dernière intervention
12 février 2020
61
Génial !!!

mille mercis!

je n'avais jamais utilisé cette formule :)

Bonne journée
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 693
Bonjour,

Simplement :
=NB.SI.ENS($C6:$AD6;$AG$2;$C7:$AD7;$AG$4)

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
78
Date d'inscription
samedi 14 février 2015
Statut
Membre
Dernière intervention
12 février 2020
61
j'ai réussi à mettre le lien du fichier.

merci je teste de suite ! :)

Cordialement,