Excel fonction semaine actuelle

Résolu/Fermé
Visiteur5475
Messages postés
18
Date d'inscription
samedi 8 février 2020
Statut
Membre
Dernière intervention
16 janvier 2022
- Modifié le 8 févr. 2020 à 19:41
Visiteur5475
Messages postés
18
Date d'inscription
samedi 8 février 2020
Statut
Membre
Dernière intervention
16 janvier 2022
- 1 mars 2020 à 13:13
Bonjour à tous,

Pouvez-vous m'aider sur le point ci-dessous svp :

Je veux calculer un nombre en fonction de la semaine actuelle, explication :

Colonne A : il y a des dates
Colonne B : des chiffres

Je veux additionner les chiffres se trouvant dans la colonne B si les dates de la colonne A correspondent à la semaine actuelle :

ex : (nous somme le 06/02)
A1 : 06/02 ---- B1 : 3
A2 : 05/02 ---- B2 : 4
A3 : 11/01 ---- B3 : 6

Je voudrais dans ma cellule "X" l’addition de la colonne B en fonction des dates de la colonne A (pour la semaine actuelle) avec comme résultat escompté le chiffre 7.
Avez-vous une formule à me donner ?
Désolé pour cette explication peu claire.
Merci d'avance pour votre aide

4 réponses

via55
Messages postés
13613
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
25 mai 2022
2 404
8 févr. 2020 à 20:07
Bonsoir

Créer une colonne C avec pour formule en C1 = NO.SEMAINE(A1) étirée ensuite

Formule pour la somme :
=SOMME.SI(C:C;NO.SEMAINE(AUJOURDHUI());B:B)

Cdlmnt
Via
1
yclik
Messages postés
2868
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
24 mai 2022
1 314
8 févr. 2020 à 20:07
Bonsoir
A tester
=SOMMEPROD(NO.SEMAINE(A2:A4;0)=NO.SEMAINE(AUJOURDHUI();0);B2:B4)
1
via55
Messages postés
13613
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
25 mai 2022
2 404
8 févr. 2020 à 20:45
Bonsoir yclik

Ta formule renvoie une erreur #VALEUR
J'avais essayé différents types de matricielles mais sans résultat, c'est NO.SEMAINE qui semble poser problème, c'est pourquoi j'ai proposé la solution d'une 3eme colonne
1
Visiteur5475
Messages postés
18
Date d'inscription
samedi 8 février 2020
Statut
Membre
Dernière intervention
16 janvier 2022

1 mars 2020 à 13:13
Merci beaucoup pour vos réponses, mon problème est résolu grâce à vos aides.
Encore merci pour votre temps ;)
0