Calculer le nombre d'un mot dans un tableau Excel. [Résolu]

Signaler
Messages postés
65
Date d'inscription
mardi 21 janvier 2020
Statut
Membre
Dernière intervention
7 mai 2020
-
Messages postés
65
Date d'inscription
mardi 21 janvier 2020
Statut
Membre
Dernière intervention
7 mai 2020
-
Bonjour à vous,

Tout d'abord, je sait qu'un autre article parle sensiblement de la même chose que moi, mais la solution ne ma pas aidé.

Dans un premier temps, je voudrais savoir comment faire en sorte de calculé le nombre de fois qu'un mot apparait dans une colonne.

Actuellement, j'ai fait une comptabilisation pour le nombre total de mes mots. Soit =SOMME(ESTTEXTE(SollicitationOuest[Région])*1).

Malheureusement, maintenant j'aimerais savoir comment faire pour comptabilisé les différents mot dans cette colonne soit (SollicitationOuest[Région]).

Exemple : J'ai actuellement 10.000 lignes et j'ai 4 différents mots dans la totalité soit ''Laval-Ouest'' / ''Fabreville'' / ''Ste-Dorothée'' / ''Chomedey''.

Est-ce possible de faire en sorte que dans une autre case (déjà établie) je puissent savoir exactement combien de fois sort le mot ''Fabreville'' et ainsi de suite.

Pour le moment, la commande plus haute ma uniquement servi pour calculé le total des mots (texte) dans ma colonne ''région'' soit, mes 10.000 lignes.

Espérant d'avoir été assez clair et précis.

Sincère salutations,

SkyDream785.

4 réponses

Messages postés
25182
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 juillet 2020
5 356
Bonjour
depuis la second image, il n'y a aucun raison que Excel vous renvoie de message avec la formule écrite sauf:
  • si votre Excel est anglais
  • si votre séparateur est la virguler au lieu du point virgule
  • si vous avez un blanc de trop au début ou à la fin ou quelqu'autre faute de frappe


toutefois, vu votre tableau, vous pouvez plutôt écrire en B28
=NB.SI($F$:F$10500;A28)
et tirer la formule de B28 à B31 pour l'associer au nom en A
en version anglaise:
=NB.SI($F$:F$10500,A28) _avec virgule ou point virgule selon les options
crtdlmnt
Messages postés
65
Date d'inscription
mardi 21 janvier 2020
Statut
Membre
Dernière intervention
7 mai 2020
4
Bonjour Vaucluse,

Je vous remercie énormément !

En effet, la commande
=NB.SI($F$:F$10500;A28)
Était la bonne de mon côté.

Merci à vous,
SkyDream785.
Messages postés
12389
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 juillet 2020
1 924
Bonsoir

Pas assez clair encore
Chaque cellule contient elle qu'un mot ou plusieurs ?
Pourquoi une formule compliquée pour compter les mots car si tu n'as que du texte un NBVAL suffisait ?
De même pour compter un mot précis un NB.SI devrait suffire
Mais ton tableau est peut être plus complexe que tu ne l'annonces

Poste un exemple de ton fichier sur mon-partage.fr, copies le lien créé et reviens le coller ici
Ce n'est qu'en étudiant ton fichier qu'on pourra t'aiguiller vers la bonne solution

Cdlmnt
Via
Messages postés
65
Date d'inscription
mardi 21 janvier 2020
Statut
Membre
Dernière intervention
7 mai 2020
4
Bonsoir via55,

Voici une image qui pourrait vous aider.

Les encadrés en rouge sont les ''choses'' concerné.

Vous verrez dans le petit tableau noir ''Nombre de prospect'' qui mène au résultat et la colonne est encadré. Sache toutefois qu'il y a 10.000 lignes, ce qui veux dire que je n'ai pas réussie a vous montrez les autres mots, mais sachez cependant que les mots dans le mini tableau à gauche sont les mots disponibles.

Veuillez ne pas noté les nombres inscrit, c'est des test qui ont été faite.

Voici le lien de mon-partage.fr : https://mon-partage.fr/f/rFtbZZch/

Vous remerciant,
Sky
Messages postés
12389
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 juillet 2020
1 924
Cela aurait été mieux d'avoir le fichier Excel plutôt qu'un image !

Néanmoins cela semble bien corroborer ce que je disais :

1) Le compte de tous les mots de la colonne se fait simplement avec NBVAL qui compte les cellules non vides, ainsi si les régions sont en colonne F la formule pour le nombre total sera =NBVAL(F:F)-1 (-1 pour enlever le mot du titre dans la colonne)

2) Le décompte d'une région se fait avec NB.SI, si région en colonne F, pour Fabreville :
=NB.SI(F:F;"Fabreville")

3) et si tu veux un décompte associé à un état de la colonne précédente c’est NB.SI.ENS qu'il faut utiliser par exemple pour compter le nombre de Fabreville avec l'état Acheté :
=NB.SI.ENS(F:F;"Fabreville";E:E;"Acheté")

Cdlmnt
Via
Messages postés
65
Date d'inscription
mardi 21 janvier 2020
Statut
Membre
Dernière intervention
7 mai 2020
4
Bonsoir à vous,

Voici ce que la commande : =NB.SI(F3:F10500;''Fabreville'') fait.

Voici le liens de l'image : https://mon-partage.fr/f/gUwO1avG/

Je ne peut malheureusement pas vous envoyer une copie de ce dossier car il contient des milliers d'adresse et d'information personnel de milliers de personne, il est donc impossible pour moi de vous remettre ce dossier, désoler.

Sincère salutations,
Sky.
Messages postés
12389
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 juillet 2020
1 924
Peut être as tu une version anglaise, essaie de remplacer le ; par une , dans la formule

Messages postés
688
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
8 juillet 2020
108
Bonsoir,

Si j'ai bien compris.... tu peux tester avec cette formule

=NB.SI(B2:B1000;"Fabreville")

Slts
Messages postés
65
Date d'inscription
mardi 21 janvier 2020
Statut
Membre
Dernière intervention
7 mai 2020
4
Bonsoir The_boss_68,

Malheureusement, cette commande ne fonctionne pas de mon côté...

Merci.
Bonjour,

Peut-être une piste.
Attention à bien orthographier "Fabreville". "Fabreville" est différent de " Fabreville" (avec 1 espace devant) ainsi que de "Fabreville " (1 espace après).
Cdlt.