Formule calcul IMC excel 2010 [Résolu]

Signaler
-
 vivi -
Bonjour,
Bonjour à tous,

Je cherche actuellement à rentrer la bonne formule (sur excel pour windows 2010) qui me permettrait d'avoir les différents indices de masse corporelle en fonction des valeurs correspondantes:

si IMC inférieur à 16,5 alors "dénutrition"
si IMC = à 16,5 ou inférieur à 18,5 alors "maigreur"
si IMC = à 18,5 ou inférieur à 25 alors "poids idéal"
si IMC = à 25 ou inférieur à 30 alors "surpoids"
si IMC supérieur à 30 alors "obésité"

IMC étant en cellule C2

Malgré plusieurs tentatives avec différentes fonctions (SI, ET,...), je n'arrive pas à retranscrire cette formule...

Si l'un d'entre vous était capable de m'aider, je lui en serait très reconnaissant, cela me rendrait un fier service !

Merci

3 réponses

Messages postés
12705
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
26 septembre 2020
2 026
Bonjour

Histoire de SI imbriqués maintes fois traitée ici :

=SI(C2<16,5;"dénutrition";si(C2<18,5;"maigreur";SI(C2<25;"poids idéal";Si(C2<30;"surpoids";"obésité"))))

Cdlmnt
Via
Messages postés
21
Date d'inscription
dimanche 8 décembre 2019
Statut
Membre
Dernière intervention
19 décembre 2019
1
Salut mon pote!

Sa tombe bien parce que je viens de réaliser un projet qui contient ce type de formule, je ne suis pas sûr si c'est la meilleure ou non mais le plus important que ça marche convenablement:
donc on va supposer que la cellule qui contient le valeur à tester est "C2":

=SI(C2<16,5;"dénutrition";SI(C2<18,5;"maigreur";SI(C2<25;"poids idéal";SI(C2<30;"surpoids";"obésité"))))
merci à tous pour vos réponses :)