Formule et dates [Résolu]

Signaler
Messages postés
15
Date d'inscription
jeudi 28 novembre 2019
Statut
Membre
Dernière intervention
29 juillet 2020
-
Messages postés
15
Date d'inscription
jeudi 28 novembre 2019
Statut
Membre
Dernière intervention
29 juillet 2020
-
Bonjour,

Je n'ai pas trouvé de réponses à mon pb dans les précédents sujets.

Si la date de ma cellule N (=Aujourd'hui() ) est comprise entre les dates de mes cellules O (supérieure ou égale) et P (inférieure ou égale) alors je voudrais que ma cellule N devienne OUI

En l'écrivant ça ne me semble pas si compliqué mais je n'y arrive pas...


Configuration: Windows / Firefox 70.0

3 réponses

Messages postés
2454
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
24 septembre 2020
1 233
Bonjour,

Essayer avec cette formule :

=SI(ET(AUJOURDHUI()>=O2;AUJOURDHUI()<=P2);"OUI";"NON")

A Vaincre sans péril, on triomphe sans gloire.
Pierre Corneille, Le Cid 
Messages postés
52325
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
14 125
Bonsoir Mariquita.

"ça ne me semble pas si compliqué mais je n'y arrive pas"
Mais oui, au contraire, c'est diablement compliqué !
En effet tu veux, dans la même cellule, à la fois écrire la formule =AUJOURDHUI() et afficher le mot "OUI" !
Mais ça ne serait envisageable qu'avec une macro en VBA ...
La proposition de diablo, que je salue amicalement, ne résout que partiellement ton problème, car sa formule (et l'affichage du OUI) n'est pas située dans la même cellule que ta formule !
Et si on écrit sa formule à la place de la tienne, on obtient l'affichage de OUI ou de NON, mais pas de la date ; à moins de modifier un peu la formule en mettant
=SI(ET(AUJOURDHUI()>=O2;AUJOURDHUI()<=P2);"OUI";AUJOURDHUI())

Tu vois que c'est un peu plus compliqué que tu ne le pensais !

Cordialement.
Messages postés
2454
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
24 septembre 2020
1 233
Comme l'a dit Raymond, le soucis est que vous voulez Remplacer votre date d'aujourd'hui en Oui ou NON. Mettre une valeur et une formule dans une même case... c'est pas possible.

C'est pour cela qu'on vous a proposé des formules qui utilise la formule AUJOURDHUI() avec des conditions.

La Formule de Raymond affiche la date du jour en cas de non correspondance, la mienne affiche non.

Concernant le ET/OU... il suffit de remplacer ET par OU, mais j'ai des doutes que ce soit vraiment ce que vous voulez, car si en O vous avez par exemple " 01/01/2012" et en P "01/01/2013" avec un OU() vous aurez la réponse "Oui".
Messages postés
15
Date d'inscription
jeudi 28 novembre 2019
Statut
Membre
Dernière intervention
29 juillet 2020

la formule écrite ainsi et ma cellule N est toujours aujourd'hui :
=SI(ET(AUJOURDHUI()>=O16;AUJOURDHUI()<=P16);"OUI";AUJOURDHUI())
ne fonctionne pas.

J'ai modifié

J'ai rajouté une colonne réduite dont le nom en N1 est AUJOURDHUI()(
dans O j'écris la formule =SI(ET($N$1>=P2;$N$1<=Q2);"OUI";"NON") ça ne marche pas non plus
Messages postés
2454
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
24 septembre 2020
1 233
Bonjour,

Vous avez peut-être un problème de format dans ce cas. Pouvez-vous vérifié le format des case P2 et Q2?

Car la je ne vois aucune erreur de formule, elle fonctionne parfaitement chez moi...
Messages postés
15
Date d'inscription
jeudi 28 novembre 2019
Statut
Membre
Dernière intervention
29 juillet 2020

Les cellules N, P et Q (et colonnes) sont en format date, en revanche bien que j'ai sélectionné le même format, certaines apparaissent sous la forme 15/11/19 et d'autres sous la forme 15/11/2019 !?
Messages postés
15
Date d'inscription
jeudi 28 novembre 2019
Statut
Membre
Dernière intervention
29 juillet 2020

pardon bonjour... me revoilà...
Messages postés
52325
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
14 125
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers
Il existe aussi :
1) https://mon-partage.fr/
2) https://www.transfernow.net/

Messages postés
15
Date d'inscription
jeudi 28 novembre 2019
Statut
Membre
Dernière intervention
29 juillet 2020

Bonjour Raymond, merci,
voici le lien :

https://www.cjoint.com/c/ILdkwHYD3yJ
Messages postés
2454
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
24 septembre 2020
1 233
Bonjour,

Je confirme il y a un soucis d'écriture et de format

Essayez en P41 de réécrire votre date 04/10/2019.

Mettez également le format Date courte
Messages postés
15
Date d'inscription
jeudi 28 novembre 2019
Statut
Membre
Dernière intervention
29 juillet 2020

Magique :)
normalement le format demandé est en date courte...
ça vient d'un extraction, est-ce que le format avant l'extraction prend le dessus? pourquoi à certaines dates et pas d'autres?
Messages postés
2454
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
24 septembre 2020
1 233
Ca dépend de comment ils ont été écrit à la base, il se peut qu'Excel conserve d'ancien format ou d'ancienne valeur qu'il essaie d'adapter au format de votre fichier.
Messages postés
15
Date d'inscription
jeudi 28 novembre 2019
Statut
Membre
Dernière intervention
29 juillet 2020

C'est magique, j'adore !!! Merci.
Je ne comprends pas pourquoi le format demandé ne s'applique pas mais maintenant ça fonctionne.

A la prochaine fois pour de nouvelles formules :D merci à vous