Récupérer la valeur d'une formule dans une autre formule [Résolu]

Signaler
Messages postés
71
Date d'inscription
mardi 26 octobre 2010
Statut
Membre
Dernière intervention
3 juin 2020
-
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
-
Bonjour,
J'ai dans la cellule B2 une formule de rechercheV qui donne un résultat ex "pomme".
Dans C2 je voudrais la formule : si(B2="pomme";"OK";"KO"), or cela m'affiche #N/A !
Pouvez-vous m'aider ?
Merci beaucoup

5 réponses

Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394
Bon jour
ça devrait fonctionner
vérifiez que dans votre base de données, pomme soit bien écrit comme dans votre formule en C2
(pas de blanc ou de caractère spécial avant ou après par exemple)
crdlmnt
Messages postés
71
Date d'inscription
mardi 26 octobre 2010
Statut
Membre
Dernière intervention
3 juin 2020

Bonjour,
j'ai bien vérifié et c'est écrit à l'identique.
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394
pour confirmer votre contrôle:
copier depuis la barre de formule le texte de la cellule qui donne le résultat dans la base de donnes et coller le texte dans la formule entre les guillemets à la place de "pomme" et voyez le résultat
Ceci dit, si votre formule affiche #N/A ce n'est pas celle de C2 qui pose problème, mais celle de B2 qui ne trouve pas le texte cherché.
et si ça ne fonctionne toujours pas, déposez un modèle ici:
http://mon-partage.fr
et revenez coller le lien créé sur le site
à vous lire
crdlmnt
Messages postés
2018
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
9 août 2020
324
Bonjour,
Un exemple de votre fichier avec explications serait le bienvenu.
Pour transmettre un fichier,
Veillez à ce qu'il n'y ait PAS DE DONNEES CONFIDENTIELLES
il faut passer par un site de pièce jointe tel que cjoint.com

Allez sur ce site : https://www.cjoint.com/
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse...
Cordialement

Messages postés
71
Date d'inscription
mardi 26 octobre 2010
Statut
Membre
Dernière intervention
3 juin 2020

Voici le tableau avec les formules identiques :
https://www.cjoint.com/c/IKzl5456cRH
Merci.
Messages postés
2018
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
9 août 2020
324 >
Messages postés
71
Date d'inscription
mardi 26 octobre 2010
Statut
Membre
Dernière intervention
3 juin 2020

Bonjour
Dans l'exemple que tu donnes il n'y a pas d'erreurs qui apparaissent
essaie avec cette formule
=SIERREUR(RECHERCHEV(B2;Vente!C2:D5;2;0);"")
Crdlt
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394 >
Messages postés
71
Date d'inscription
mardi 26 octobre 2010
Statut
Membre
Dernière intervention
3 juin 2020

pouvez vous expliquer pourquoi dans votre exemple, le code EQUIV en B2 fait référence à A1? (décalage incongru bien que le résultat soit correct
Mais dans tous les cas votre exemple ne donne pas le type d'écriture de vos textes réels probablement à l'origine de votre problème
voyez par exemple si vous rajoutez un blanc derrière Paul en colonne A de Vente
Dans votre "vrai" fichier, essayez de faire cette manip:
copier les cellules de B feuille Vente et les coller "spécial valeur" sur les cellules des valeurs à chercher
Messages postés
71
Date d'inscription
mardi 26 octobre 2010
Statut
Membre
Dernière intervention
3 juin 2020

çà ne fonctionne pas, dans mon tableau si je colle la valeur trouvée, là çà fonctionne !
Cdt
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394
alors c'est que la valeur que vous trouvez n'est pas écrite de la même façon dans la base de données et-dans votre formule, mais sans le modèle, on ne peut rien vous dire de plus
Messages postés
489
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
7 août 2020
22
Bonjour,

Essaie avec ça
=SI(ESTNA(B2);"KO";SI(B2="pomme";"OK"))

Cordialement
Messages postés
71
Date d'inscription
mardi 26 octobre 2010
Statut
Membre
Dernière intervention
3 juin 2020

Il me faut la recherchev car les données sont dans une autre feuille.
Cdt
Messages postés
71
Date d'inscription
mardi 26 octobre 2010
Statut
Membre
Dernière intervention
3 juin 2020

En fin de compte (dans mon tableau réel) quand je mets VRAI dans ma formule de rechercheV, j'ai le bon résultat et si je mets FAUX, j'ai #N/A !

Avez-vous une solution ?
Merci
Messages postés
489
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
7 août 2020
22
Bonjour,

Comme l'a dit JCB40, dans ton tableau exemple il n'y a pas d'erreurs qui apparaissent !
Alors donne une copie (ou extraction partielle) de ton tableau réel avec tes formules et/ou clarifie tes premières explications :
J'ai dans la cellule B2 une formule de rechercheV qui donne un résultat ex "pomme".
Dans C2 je voudrais la formule : si(B2="pomme";"OK";"KO"), or cela m'affiche #N/A !


Cordialement
Messages postés
71
Date d'inscription
mardi 26 octobre 2010
Statut
Membre
Dernière intervention
3 juin 2020

Bonjour à tous et merci.
L'erreur venait du fait que le format des données de la feuille 2 n'était pas identique à la feuille 1.
Bonne journée.
Cdt,
Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 394
éh bé voila
je passe le sujet en résolu
crdlmnt