Fonction NB.SI avec comme critère la fonction DROITE

Résolu/Fermé
nlbmoi Messages postés 434 Date d'inscription samedi 26 août 2006 Statut Membre Dernière intervention 3 septembre 2022 - 14 nov. 2019 à 21:14
Raymond PENTIER Messages postés 56840 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 28 novembre 2022 - 15 nov. 2019 à 01:54
Bonjour

Je dois compter le nombre d'équipe par genre à partir du niveau : la dernière lettre du niveau correspondant au genre.
J'ai voulu essayer une formule du type NB.SI.ENS(DROITE(B2;1);"M") mais je rencontre une erreur.
J'ai vu qu'il était possible d'utiliser sommeprod : j'ai essayé une formule du type SOMMEPROD((DROITE(B2;1)="M")*1) + ... qui fonctionne mais n'y a-t-il pas une formule plus raccourcie qui prend en compte une plage de cellules ?
Merci d'avance

Mon fichier : https://www.cjoint.com/c/IKoun5PSKX8

1 réponse

via55 Messages postés 13965 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 27 novembre 2022 2 520
14 nov. 2019 à 22:15
Bonsoir

Essaye plutôt
=NB.SI(B2:B5;"*M")

Cdlmnt
Via
2
Raymond PENTIER Messages postés 56840 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 28 novembre 2022 17 178
15 nov. 2019 à 01:54
... et y'a pas plus raccourci !
0