Fonction NB.SI avec comme critère la fonction DROITE [Résolu]

Signaler
Messages postés
407
Date d'inscription
samedi 26 août 2006
Statut
Membre
Dernière intervention
23 septembre 2020
-
Messages postés
52455
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
18 octobre 2020
-
Bonjour

Je dois compter le nombre d'équipe par genre à partir du niveau : la dernière lettre du niveau correspondant au genre.
J'ai voulu essayer une formule du type NB.SI.ENS(DROITE(B2;1);"M") mais je rencontre une erreur.
J'ai vu qu'il était possible d'utiliser sommeprod : j'ai essayé une formule du type SOMMEPROD((DROITE(B2;1)="M")*1) + ... qui fonctionne mais n'y a-t-il pas une formule plus raccourcie qui prend en compte une plage de cellules ?
Merci d'avance

Mon fichier : https://www.cjoint.com/c/IKoun5PSKX8

1 réponse

Messages postés
12774
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 octobre 2020
2 043
Bonsoir

Essaye plutôt
=NB.SI(B2:B5;"*M")

Cdlmnt
Via
Messages postés
52455
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
18 octobre 2020
14 316
... et y'a pas plus raccourci !