Combinaison fonctions [Résolu]

Signaler
Messages postés
14
Date d'inscription
lundi 21 octobre 2019
Statut
Membre
Dernière intervention
24 octobre 2019
-
Messages postés
14
Date d'inscription
lundi 21 octobre 2019
Statut
Membre
Dernière intervention
24 octobre 2019
-
Bonjour,

svp, j'aimerai bien avoir vos aides apropos de ma recherche.

j'ai un tableau de gestion d'absences.
Colonne A=Matricule Employé
Colonne B=Nom & Prenom
Colonne C>>AG Les jours du mois
les absences sont referencie par des clés par ex: (Maladie=M; Non justifie=N.J; Personnel=P)
le but c'est quand on mentionne un Matricule le resultat soit : l'employé X (M:1 ; P:3 N.J:2) sachant que j'ai essayé avec NB.SI/RECHARCHEV/SI mais sans resultat.

Merci de vos interventions.

6 réponses

Messages postés
12477
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 août 2020
1 961
Bonjour

En procédant ainsi :
https://mon-partage.fr/f/egtv7frC/

Cdlmnt
Via
Messages postés
14
Date d'inscription
lundi 21 octobre 2019
Statut
Membre
Dernière intervention
24 octobre 2019

MRC BCP pour Votre reponse Apparement, ca ne veut pas marcher avc moi ):):):
Messages postés
14
Date d'inscription
lundi 21 octobre 2019
Statut
Membre
Dernière intervention
24 octobre 2019

et beh ca fonctionne mnt tres bien merci merci merci mecri bcp

salutations.
Messages postés
14
Date d'inscription
lundi 21 octobre 2019
Statut
Membre
Dernière intervention
24 octobre 2019

Dsl Mon cher,

au debut ca a marché mais aprés me donne que 0 pour tous les resultats.

je ne sais pas quoi faire.
Messages postés
12477
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 août 2020
1 961
Simplement la formule doit être :
=NB.SI(DECALER($C$6:$AG$6;EQUIV($AJ$7;$A$7:$A$97;0););"C")
et toi tu as mis :
=NB.SI(DECALER($C$7:$AG$7;EQUIV($AJ$7;$A$7:$A$97;0););"C")

Messages postés
14
Date d'inscription
lundi 21 octobre 2019
Statut
Membre
Dernière intervention
24 octobre 2019

Parceque La cellule C6 ne contient que le titre donc on peut pas appliquer la formule sur un titre alors qu'on cherche soit le "matricule" ou "Nom Employé" plage des données commence du C7, N'est ce pas?
Messages postés
9525
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
7 août 2020
1 877
Bonjour

Peux tu envoyer un bout de ton fichier sur https://mon-partage.fr/ et joindre le lien obtenu à ton prochain message. N'oublies pas d'y ajouter des explications et des exemples de résultat attendu.

Cdlmnt
Messages postés
14
Date d'inscription
lundi 21 octobre 2019
Statut
Membre
Dernière intervention
24 octobre 2019

Bonjour,

merci de votre intervention.

Voici le lien https://mon-partage.fr/f/z9qN0xTj/
Messages postés
2725
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
8 août 2020
701
Bonjour

Tu veux ça comment ? dans plusieurs cellules ou tout dans une seule (hormis le matricule ; ça va de soit)

Il nous faudrait une copie du fichier épuré de toutes les données confidentielles et avec au moins un exemple du résultat attendu

Faire créer un lien sur l'un de ces sites
https://www.cjoint.com/
https://mon-partage.fr/
https://www.transfernow.net/

Copier le lien et venir le coller sur le prochain message

Cordialement
Messages postés
14
Date d'inscription
lundi 21 octobre 2019
Statut
Membre
Dernière intervention
24 octobre 2019

https://mon-partage.fr/f/z9qN0xTj/
Messages postés
12477
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 août 2020
1 961
???

Renvoie me le fichier qui renvoie des 0
Messages postés
14
Date d'inscription
lundi 21 octobre 2019
Statut
Membre
Dernière intervention
24 octobre 2019

https://mon-partage.fr/f/lP8c1vLq/
Messages postés
12477
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 août 2020
1 961
Si!
On n'applique pas la formule sur le titre, on fait décaler la plage de recherche du nombre de lignes équivalent à la position du matricule dans la liste
Donc la plage de départ est bien celle des titres, au 1er matricule on fait décaler de 1 donc la plage lue par la formule est la ligne 7, au 4eme matricule la plage lue est la ligen 10 etc..
Messages postés
14
Date d'inscription
lundi 21 octobre 2019
Statut
Membre
Dernière intervention
24 octobre 2019

Merci Bcp mon cher pour toutes vos explications. c’était exactement mon problème avec cette formule car je pensais que je dois commencer tjrs avec la première cellule qui contienne les données recherchées apparemment vous m'avez tout expliqué.

Merci infiniment.