Fonction Si qui renvoie d'office condition fausse [Résolu]

Signaler
Messages postés
2
Date d'inscription
dimanche 20 octobre 2019
Statut
Membre
Dernière intervention
20 octobre 2019
-
Messages postés
2
Date d'inscription
dimanche 20 octobre 2019
Statut
Membre
Dernière intervention
20 octobre 2019
-
Bonjour,

Je me trouve face à un casse-tête chinois incompréhensible... Ça doit être tout bête mais je comprends pas...

J'ai :
A1 dans laquelle je rentre une heure de 0 à 24h
B1=A1*24 (transformation heure en nombre)
C1 avec une valeur quand l'heure est entre 7h et 18h
D1 avec une valeur quand C1 est fausse

E1 =SI(7<=B1<18;C1;D1)

Mon problème, E1 me renvoie systématiquement la valeur D1, peu importe l'heure que je rentre...

Au secours je m'arrache les cheveux...

Merci d'avance
Fulgrim

Configuration: Android / Chrome 77.0.3865.116

3 réponses

Messages postés
25207
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 août 2020
5 387
Bonjour
utilisez le ET pour grouper les conditions simultanées
=SI(ET(7<=B1;B1<18);C1;D1)
crdlmnt

Messages postés
2710
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
3 août 2020
693
Bonjour

essayez :

=SI(ET(B1>=7;B1<18);C1;D1)

Cordialement
Messages postés
2
Date d'inscription
dimanche 20 octobre 2019
Statut
Membre
Dernière intervention
20 octobre 2019

Au top ! Probleme résolu merci beaucoup