Formules Condition combinées avec la gestion de la cellule vide.

Résolu/Fermé
Mandelle_9316 Messages postés 3 Date d'inscription jeudi 10 octobre 2019 Statut Membre Dernière intervention 10 octobre 2019 - 10 oct. 2019 à 19:59
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 - 11 oct. 2019 à 07:06
Bonjour,

Je dois calculer l'age d'enfants en fonction de leur date de naissance et indiquer "new born" lorsqu'ils ont moins d'un mois.
J'ai donc appliqué la formule :
=SI(ET(DATEDIF(B11;AUJOURDHUI();"y")=0;DATEDIF(B11;AUJOURDHUI();"ym")=0); "new born"; DATEDIF(B11;AUJOURDHUI();"y") & "a " & DATEDIF(B11;AUJOURDHUI();"ym") & "m ")

Par contre, comment ajouter le fait que cela m'affiche : cellule vide en résultat si ma cellule Date de naissance = B11 est vide.

Merci d'avance.

2 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 307
10 oct. 2019 à 20:42
bonsoir

=SI(B11="";"cellule vide";SI(ET(DATEDIF(B11;AUJOURDHUI();"y")=0;DATEDIF(B11;AUJOURDHUI();"ym")=0); "new born"; DATEDIF(B11;AUJOURDHUI();"y") & "a " & DATEDIF(B11;AUJOURDHUI();"ym") & "m "))
crtdlmnt
1
Mandelle_9316 Messages postés 3 Date d'inscription jeudi 10 octobre 2019 Statut Membre Dernière intervention 10 octobre 2019
10 oct. 2019 à 20:55
Merci, mais je perds le résultat "new born" si je rentre la date de naissance 25/09/2019.
0
Mandelle_9316 Messages postés 3 Date d'inscription jeudi 10 octobre 2019 Statut Membre Dernière intervention 10 octobre 2019
10 oct. 2019 à 20:59
désolée, j'avais un espace de trop dans ma formule : avec votre modification elle fonctionne très bien.

Merci beaucoup. Bonne soirée.
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 307
11 oct. 2019 à 07:06
pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt
0