Raccourcir un formule [Fermé]

Signaler
Messages postés
9
Date d'inscription
jeudi 26 septembre 2019
Statut
Membre
Dernière intervention
30 septembre 2019
-
Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
-
Bonjour a tous,

Est-il possible de raccourcir cette formule :

=SI(A1="ADISTA";CURATIVE!C3;SI(A1="AXIONE";CURATIVE!C4;SI(A1="BLUE COM";CURATIVE!C5;SI(A1="BOUYGUES";CURATIVE!C6;SI(A1="BRISTISH";CURATIVE!C7;SI(A1="CELESTE";CURATIVE!C8;SI(A1="CM'IN";CURATIVE!C9;SI(A1="COVAGE";CURATIVE!C10;SI(A1="FREE";CURATIVE!C11;SI(A1="GIGALIS";CURATIVE!C12;SI(A1="INTEROUTE";CURATIVE!C13;SI(A1="LOTIM";CURATIVE!C14;SI(A1="MELISA";CURATIVE!C15;SI(A1="SARTEL";CURATIVE!C16;SI(A1="SFR";CURATIVE!C18;SI(A1="SIPARTECH";CURATIVE!C19;SI(A1="SOGEA";CURATIVE!C20;SI(A1="TOURS";CURATIVE!C21;SI(A1="TUTOR";CURATIVE!C22;SI(A1="VERIZON";CURATIVE!C23;""))))))))))))))))))))

Merci d'avance :)

Bonne journée a tous !!

3 réponses

Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
5 490
Bonjour
avec une base de données:
par exemple en Y1:Y20 la liste des textes possibles en A1,et en Z en ligne, les N° de ligne des cellules C à ressortir

=INDIRECT(ADRESSE(RECHERCHEV(A1;Y:Z;2;0);3;;;"CURATIVE"))

crdlmnt


Messages postés
9
Date d'inscription
jeudi 26 septembre 2019
Statut
Membre
Dernière intervention
30 septembre 2019

sa ne marche pas .. mais merci :)
Bonjour,

Sans liste ...
=INDIRECT("CURATIVE!C"&2+EQUIV(A1;{"ADISTA";"AXIONE";"BLUECOM";"BOUYGUES";"BRISTISH";"CELESTE";"CM'IN";"COVAGE";"FREE";"GIGALIS";"INTEROUTE";"LOTIM";"MELISA";"SARTEL";"SFR";"SIPARTECH";"SOGEA";"TOURS";"TUTOR";"VERIZON"};0))


Note bien que la proposition de Vaucluse fonctionne aussi bien si tu peux insérer la liste ...

Cordialement.
Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
5 490
Re
alors dites nous ce qui ne va pas dans ce modèle
https://mon-partage.fr/f/cG9TGfuj/

gyrus: (salut ami).. pour info, si on regarde la formule d'origine il manque le C17, et si ça n'est pas une erreur, cela limite ta proposition à C16 sauf comme je l'ai fait, à rajouter une valeur bidon. entre 16 et 18

crdlmnt