Simplification Formule de 19 Lignes [Résolu/Fermé]

Signaler
Messages postés
19
Date d'inscription
jeudi 26 octobre 2017
Statut
Membre
Dernière intervention
24 août 2019
-
Messages postés
19
Date d'inscription
jeudi 26 octobre 2017
Statut
Membre
Dernière intervention
24 août 2019
-
Bonjour,

J'ai un fichier destiné à la consommation de Matière Première consommé pour chaque type de machine en fonction de nbr de machine

J'ai essayé de profiter de la fonction SommeProd, mais sans résultat, j'évite les Macro,car le fichier original est devenu trop lourd

J'ai dû donc écrire une formule de 19Lignes ! pour passer cellule par cellule :'(

Le fichier: https://www.cjoint.com/c/IHym2u7vvPb



Configuration: Windows / Chrome 76.0.3809.100

2 réponses

Messages postés
2835
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
29 octobre 2020
767
Bonjour,

Si vous nous expliquiez ce que vous chercher à obtenir, ça serait mieux, n'est-ce-pas !

Dans la formule de toute façon il y a une erreur, dans G2 vous n'avez pas bloqué la zone de recherche

BD_Formule!A1:D464 devrait être BD_Formule!$A$1:$D$464 ;

en incrémentant vers le bas ça aurait évité qu'en G3 la zone de recherche passe à BD_Formule!A2:D465 et ainsi de suite....

Pour éviter cela il serait utile de nommer cette zone et faire référence à ce nom dans la formule

Cordialement
Messages postés
19
Date d'inscription
jeudi 26 octobre 2017
Statut
Membre
Dernière intervention
24 août 2019

Bonjour PapyLuc51

J'ai pas fait attention au blocage dela plage de recherche, merci pour la remarque

sinon, ci-dessus, une proposition de soltion,

si vous avez autre methode, j'en serait ouvert
Messages postés
19
Date d'inscription
jeudi 26 octobre 2017
Statut
Membre
Dernière intervention
24 août 2019

Soution trouvé, merci à Dranreb
https://www.cjoint.com/c/IHypIMMAIWb

Je crains qu'il ne faille insérer une colonne E en BD_Formule.
Pour compter le nombre de chaque machine choisi dans la page principal
=SOMME.SI(Principal!$A$2:$A$35;$B2;Principal!$B$2:$B$35)

En 'Principal'!G2, à propager sur 400 lignes :
=SOMMEPROD(N(BD_Formule!$C$2:$C$463=$F2);BD_Formule!$D$2:$D$463;BD_Formule!$E$2:$E$463)

Pour faire la somme des multiplications de chaque machine avec 3 critères:
critère 1: verification que chaque MP choisie dans la page principal correspond à MP de Machine selectionné
critère 2: extraire la dose de la machine selectionné
critère 3: extraire le nbr de machine grace àa la formule inserer en colonne E de la feulle BD_Formule

puis faire le produit des 3 critères

L'astuce magic, c'est la Fonction "[b]N[/b]" qui suit directement la fonction SommeProd : elle sert à renvoyer "1" ou "vrais" si le critère 1 est correcte sinon renvoie 0

j'espère que ça pourra servir à d'autre personnes
https://www.cjoint.com/c/IHypIMMAIWb