Formule EXCEL [Résolu]

Signaler
Messages postés
4
Date d'inscription
mercredi 14 août 2019
Statut
Membre
Dernière intervention
16 août 2019
-
Messages postés
4
Date d'inscription
mercredi 14 août 2019
Statut
Membre
Dernière intervention
16 août 2019
-
Bonjour,

J'ai fait une recherche V mais malheusement il faut que les cellules soient identiques.

Quel est la formule suivante svp:

Exemple:

Tableau 1:

celllule A: designation produit + référence produit
Cellule B : Quantité commandés

Tableau 2:

cellule A: référence produit
Cellule B : (formule qui retrouve la quantité commandé de la référence produit dans le tableau 1)

J'ai fait une recherche V mais ça n'as pas marché car la cellule A du Tableau 1 contient référence produit et n'est pas égale à référence produit du tableau 2.

2 réponses

Messages postés
12477
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 août 2020
1 961
Bonjour

1° ton tableau enfreint une des règles de base d'une BDD : une info par cellule, il faudrait une colonne pour la désignation et une colonne pour la référence

2° Pour pallier cela il faut inclure dans ta recherchev qu’il peut y avoir n'importe quoi avant la ref avec le signe *
Pour chercher par ex la ref 145G ta formule est :
=RECHERCHEV("*" & "145G";A:B;2;0)

Cdlmnt
Via
Messages postés
4
Date d'inscription
mercredi 14 août 2019
Statut
Membre
Dernière intervention
16 août 2019

Mais j'ai plusieurs lignes de référence. Donc comment faire? car je peut pas remettre la référence en question pour chaque cellule.

Merci.
Messages postés
12477
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 août 2020
1 961
Re,

Tout dépend de ce que tu veux obtenir :

- soit le montant pour une réf que tu peux changer; à ce moment mettre la référence dans une cellule par ex G1 et la formule devient =RECHERCHEV("*" & G1;A:B;2;0) quand tu changes la ref en G1 le résultat change en fonction

- soit les montants pour toutes les références; alors il faut faire la liste des références en colonne G par ex, en H1 mettre la même formule que celle indiquée ci dessus et l'étirer au bas de la colonne

Si c'est autre chose précise davantage ce que tu veux et poste un exemple de ton fichier sur mon-partage.fr, copié le lien créé et reviens le coller ici

Cdlmnt
Messages postés
4
Date d'inscription
mercredi 14 août 2019
Statut
Membre
Dernière intervention
16 août 2019

RECHERCHEV("*"&B191;[19AC06_HSMatérielHSD.xls]Feuil2!$A$2:$C$609;3;0)

Voici ce que j'ai fait, mais cela me met une non valeur?!
Messages postés
4
Date d'inscription
mercredi 14 août 2019
Statut
Membre
Dernière intervention
16 août 2019

Re,

YOUPII. ça a marché. j'ai retrouvé une de tes anciennes réponses d'un autre forum qui avait le même problème que moi et en faite il fallait que je rajoutes &"*" après B191.

Merci BEAUCCOOUUPPP!!!