Correction formule [Résolu]

Signaler
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020
-
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020
-
Bonjour mes amis,

cette formule consiste à trouver les 3 premiers chiffres de la cellule J8, et les chercher dans la colonne A et faire la somme de ses correspondants, exemple:

Col A / Col C
441 / 100
100/ 20
200 / 30
441/ 100
210/ 500
441/ 120

le resultat sera: 320

ma question : est ce qu'il est possible d'avoir une formule qui travaille sur n'importe quel nombre de caractère dans la cellule J8 et n'est pas les 3 premiers chiffres???

Merci infiniment

1 réponse

Messages postés
2207
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
2 juillet 2020
1 097
Bonjour,

Quel est votre formule actuelle? ( vous parlez de correction ce serait bien de savoir quelle formule corrigée)

Que voulez-vous dire par "n'importe quel nombre de caractère dans la cellule J8 et n'est pas les 3 premiers chiffres??? "

X Chiffres, peu importe leur placement, ou X chiffres au début?

Comment vous allez déterminer le nombre x.
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

Nn juste les nombres,

il doit ajouter le chiffre, mais je n'ai pas de probleme avec 3 caracteres en J8, le probleme c'est dans 4 caracteres et plus.

Merci
Messages postés
2207
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
2 juillet 2020
1 097
Pourquoi ne pas faire simplement avec un somme.SI ?

=SOMME.SI(A:A;J8;C:C)

Ca permet de chercher J8 en A, Si ya correspondance une somme se fait des valeurs en C
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

Parce que si je cherche 4411 et j'ai 4411000000 dans colonne A:A je ne recois pas la somme.
Messages postés
2207
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
2 juillet 2020
1 097
C'est ce que j'ai demandé plus haut... et vous m'avez dit non ....

Pouvez-vous essayé avec cette formule:
=SOMMEPROD(EXACT(GAUCHE(A1:A29;NBCAR(J8));J8)*C1:C29)
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

Merci infiniment