Formule de calcul de répétition d'une variable [Résolu]

Signaler
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020
-
Messages postés
12389
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 juillet 2020
-
Bonjour mes amis,

je demande votre aide pour savoir une formule de calcul:

exemple: j'ai une variable dans cellule A1="Paris"
et dans la plage de la feuille il se repete ce nom plusieurs fois.
exemple : Dans E15 et F15 = "Paris" et "oui"
Dans C10 et D10 = "Paris" et "oui"


la question est : si je cherche "Paris" combien le mot "oui" se repete???

Merci infiniment



Configuration: Windows / Firefox 52.0

7 réponses

Messages postés
12389
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 juillet 2020
1 924
Bonjour

Pas très clair
Apparemment Paris peut se trouver dans diverses colonnes ?

Fournis ton fichier en le postant sur mon partage.fr, fais créer un lien que tu copies et reviens coller ici

Cdlmnt
Via
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

Voila le fichier explicatif : https://www.cjoint.com/c/IGsoWcyCaHK

Merci infiniment
Messages postés
12389
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 juillet 2020
1 924
Ok c'est succint comme tableau

Ici les Paris sont dispatchés sur 3 colonnes
Est ce toujours le cas où peut il y en avoir plus ou moins ?

Par formule simple ce ne sera peut être pas évident il faudra passer alors par une fonction personnalisée en VBA
J'attends ta réponse pour déterminer la marche à suivre

Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

c'est mieux une formule simple, est ce qu'il est possible de faire une recherche sur toute la plage de la feuil?? Merci
Messages postés
12389
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 juillet 2020
1 924
Tu ne réponds pas à ma question
Combien de colonnes ??
Et se suivent elles ?
Fournis un tableau plus complet et proche du réeel si tu veux une réponse éfficace
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

Les colonnes de A à H, et dzl pour le tableau je ne l'ai pas mtn merci
Messages postés
12389
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 juillet 2020
1 924
en 1ere ligne au dessus du tableau de chaque colonne où il y a des Paris tu mets une formule de ce type :
=NB.SI.ENS(C4:C20;"paris";D4:D20;"oui") à adapter
ici on a des Paris en colonne C depuis la ligne 4 à la ligne 20 et donc des oui en D4:D20

Ensuite il ne reste que dans la cellule où tu veux le résultat de faire la somme des nombres en ligne 1
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

je pense que la formule ne marche pas en excel 2003? je recois #NOM?
Messages postés
12389
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 juillet 2020
1 924
Il y a des chances, alors emplace là apr celle-ci :
=SOMMEPROD((C4:C19="paris")*(D4:D19="oui"))
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

comment puis je chercher sur colonne C : D et F : G au meme temps??
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

cette fonction ne marche pas??

=SOMMEPROD((C4:C19=A1)*(D4:D19="oui")*OU(((F4:F19=A1)*(G4:G19="oui"))))
Messages postés
12389
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 juillet 2020
1 924
Non

=SOMMEPROD((C4:C19=A1)*(D4:D19="oui") + SOMMEPROD((F4:F19=A1)*(G4:G19="oui")
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

non celui la:
=SOMMEPROD((C4:C19=A1)*(D4:D19="oui")+((F4:F19=A1)*(G4:G19="oui")))

Merci infiniment
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

Merci bouceaup a votre aide
Messages postés
12389
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 juillet 2020
1 924
De rien
Passe en résolu (le triangle avec ! tout en haut à droite
Bonne suite