Problème upgrade [Fermé]

Signaler
-
 salade -
Bonjour,
Bonjour,

J'ai un raspberry pi3 et je suis complètement novice.

J'ai un souci avec la commande "sudo apt-get dist-upgrade".

En effet, le message suivant s'affiche et je suis perdue.

Je vous remercie d'avance pour votre aide pour comprendre et remédier à ce problème.

"sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
libsdl1.2-dev : Dépend: libcaca-dev mais il n'est pas installé
Dépend: libdirectfb-dev (>= 0.9.22) mais il n'est pas installé
Dépend: libglu1-mesa-dev mais il n'est pas installé ou
libglu-dev
Dépend: libpulse-dev mais il n'est pas installé
Dépend: libxext-dev mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
XXXXXX :~ $ apt-get -f install
bash: apt-get : commande introuvable"


Configuration: Macintosh / Safari 6.0

2 réponses

Messages postés
35316
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
3 août 2020
5 313
Salut,
XXXXXX :~ $ sudo apt-get -f install
;-))

2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 56981 internautes nous ont dit merci ce mois-ci

Bonjour,

J'ai encore des problèmes à ce sujet..

Voici le message qui s'affiche après avoir rectifié la commande :

XXXXXXX:~ $ sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... a échoué.
Les paquets suivants contiennent des dépendances non satisfaites :
libsdl1.2-dev : Dépend: libcaca-dev mais il n'est pas installé
Dépend: libdirectfb-dev (>= 0.9.22) mais il n'est pas installé
Dépend: libglu1-mesa-dev mais il n'est pas installé ou
libglu-dev
Dépend: libpulse-dev mais il n'est pas installé
Dépend: libxext-dev mais il n'est pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances
Messages postés
35316
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
3 août 2020
5 313
Re-

L'installation est récente de ton raspberry ? (si oui, peut-être serait-il plus raisonnable de repartir sur une installation saine ?)

Qu'as-tu installé pour en arriver là ?
Merci pour ton aide..

Comme on me l'a offert, je ne sais pas ce qui a été fait avant.