Excel 2016 - trouver l'age en fonction d'une date de naissance [Résolu/Fermé]

Signaler
Messages postés
107
Date d'inscription
mercredi 17 mars 2004
Statut
Membre
Dernière intervention
12 janvier 2020
-
Messages postés
107
Date d'inscription
mercredi 17 mars 2004
Statut
Membre
Dernière intervention
12 janvier 2020
-
Bonjour,

Pour excel 2016
Dans une liste de membres d'une association, je voudrais, dans une colonne à côté de celle de la "date de naissance" calculer automatiquement l'âge de la personne.

Quelqu'un pourrait-il me donner la procédure à utiliser ?

merci


Configuration: Windows 10 - Firefox - pack office 2016

5 réponses

Messages postés
2091
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
1 juillet 2020
276
Bonjour,

Date de naissance en colonne A
Age en colonne B
en B2: =TEXTE(AUJOURDHUI()-A2;"aa")*1

ensuite; clic droit sur la cellule, "Format de cellule", "Personalisée", dans "Type", écrivez
00" ans"
Ok

Sélectionnez B2 et tirez vers le bas

Cdlt
Messages postés
2091
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
1 juillet 2020
276
Pour le format personnalisé, remplacez 00" ans" par ##0" ans"
Messages postés
107
Date d'inscription
mercredi 17 mars 2004
Statut
Membre
Dernière intervention
12 janvier 2020
3
Merci, merci, merci Frenchie83
Une question complémentaire, s'il te plait :

Je voudrais que seul apparaisse le nombre d'années, mais pas le mot "ans" de manière à pouvoir faire une moyenne (que d'ailleurs je ne sais pas faire), ou une médiane (que je ne sais pas faire non plus).

Pourrais tu encore m'aider s'il te plait ?
Messages postés
25160
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
5 345
Bonjour (et salut Frenchie)
Un peu plus direct pour avoir le nombre d'années en numérique:
avec date de naissance en A1:

=DATEDIF(A1;AUJOURDHUI();"y")

crdlmnt
Messages postés
107
Date d'inscription
mercredi 17 mars 2004
Statut
Membre
Dernière intervention
12 janvier 2020
3
Ben là, j'ai un problème
l'àge est en D2
la date de naissance en C2

- en D2, j'ai écrit : =DATEDIF(C2;AUJOURDHUI();"y")
En résultat en D2 j'ai toujours le nombre d'années et le mot "ans", je voudrais n'avoir que le nombre d'années
J'ai beau chercher je ne vois pas quelle erreur j'ai fait dans ma formule
(sachant que je ne suis pas vraiment une lumière en XL... mais que j'ai bien d'autres qualités qui ici ne me servent à rien)
Messages postés
25160
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
5 345
si vous avez "ans" en résultat, c'est que votre cellule est formatée en personnalisé et donc que sa valeur reste numérique, le texte du formatage n'étant pas pris en compte
vous pouvez donc utiliser ces résultats en l'état pour d'autres calculs
voyez pour vérifier avec cette manip:
format de cellule nombre standard
et là, vous n'aurez que le nombre

crdlmnt
Messages postés
107
Date d'inscription
mercredi 17 mars 2004
Statut
Membre
Dernière intervention
12 janvier 2020
3
Ça marche !

Et pour faire la moyenne d'age STP ?
Messages postés
25160
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
5 345
pour une colonne d'âge de B1 à B100
sur le total
=MOYENNE(B1:B100)
sur une information spécifique en A1:A100 par exemple F pour femme et H pour homme
=MOYENNE.SI(A1:A100;"F";B1:B100)
spécifier entre guillemets si texte, ici F pour femmes
sur une tranche d'âge exemple entre 15 et 40
=MOYENNE.SI.ENS(B1:B100;B1:B100;">15";B1:B100;"<40")
et combiner les deux
=MOYENNE.SI.ENS(B1:B100;B1:B100;">15";B1:B100;"<40";A1:A100="F")

crdlmnt
Messages postés
107
Date d'inscription
mercredi 17 mars 2004
Statut
Membre
Dernière intervention
12 janvier 2020
3
Merci à vous deux, vous avez été super tant au niveau des solutions proposée que de la réactivité
Je vous souhaite un très bon dimanche