Formule index equiv [Résolu/Fermé]

Signaler
Messages postés
2059
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
12 septembre 2020
-
Messages postés
2059
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
12 septembre 2020
-
Bonjour,
J'ai une erreur que je ne trouve pas sur cette formule,
https://www.cjoint.com/c/IFdmjiubZLk
Ou se trouve le problème?
Cordialement


Configuration: Windows / Firefox 67.0

5 réponses

Messages postés
2091
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
19 septembre 2020
817
Bonsoir
une proposition
la difficulté est de traiter le exæquo car la fonction EQUIV done la 1ère valeur trouvée
reste à traiter les erreurs

peut être plus simple de mettre le classement trié en colonne
exemple
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60526 internautes nous ont dit merci ce mois-ci

Messages postés
2059
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
12 septembre 2020
339
Bonjour
Merci pour ton aide.
Je te joins le fichier modifié avec nouvelles explications
https://www.cjoint.com/c/IFdpKfUMlek
Cordialement
Messages postés
2091
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
19 septembre 2020
817
pas plus de solution
Messages postés
2091
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
19 septembre 2020
817
Autre proposition


A recopier à droite et en bas
en c2
=SI($A2=C$1;LIGNE();"")


en G2
=INDEX($B$2:$B$10;EQUIV(PETITE.VALEUR(C$2:C$10;LIGNE()-1);C$2:C$10);0)


en K2 avec traitement erreur
=SI(ESTERREUR(PETITE.VALEUR(C$2:C$10;LIGNE()-1));"";INDEX($B$2:$B$10;EQUIV(PETITE.VALEUR(C$2:C$10;LIGNE()-1);C$2:C$10);0))		
Messages postés
16209
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 septembre 2020
3 031
Bonjour,

https://mon-partage.fr/f/bnU3gRbR/

on devrait pouvoir le faire avec une seule formule matricielle pour chaque cas(1,2,3) mais pour l'instant je sèche...

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60526 internautes nous ont dit merci ce mois-ci

Messages postés
2059
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
12 septembre 2020
339
Après réflexion je ne sais même pas si j'utilise la bonne formule
Messages postés
2059
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
12 septembre 2020
339
Re bonjour
Quelle est la bonne formule que je dois utiliser dans mon tableau pour avoir le résultat souhaité?
Cordialement
Messages postés
2059
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
12 septembre 2020
339
Bonjour yclick et michel

Merci pour votre aide.
J'étais loin avec ma formule
Désolé yclick j'ai adopté la solution de michel qui est plus simple.
Mais je garde ta solution en stock.
Cordialement
Bonne soirée