Copie [Résolu/Fermé]

Signaler
Messages postés
34
Date d'inscription
mardi 12 juin 2018
Statut
Membre
Dernière intervention
26 juin 2020
-
Messages postés
34
Date d'inscription
mardi 12 juin 2018
Statut
Membre
Dernière intervention
26 juin 2020
-
Bonjour,

Je voudrais savoir si c’est possible de copier les colonnes L & M sur B & C sans effacer les formules entre les 2 sur B & C (mon fichier contient des centaines de lignes et non 26 lignes comme l'exemple).

Merci

https://www.cjoint.com/c/IErmBER2Hzf

6 réponses

Messages postés
673
Date d'inscription
mardi 27 septembre 2011
Statut
Membre
Dernière intervention
17 mai 2019
53
Bonjour,

Soit tu as une valeur écrite, soit une formule,
Quel est l'intéret, pour toi, d'avoir les deux dans une même cellule ?
Y'a t'il une priorité entre les deux ?
Ex : Si L est vide alors faire rechercheV, ou alors si rechercheV n'est pas trouvable alors inscrire L

Merci,

Lentzouille
Messages postés
34
Date d'inscription
mardi 12 juin 2018
Statut
Membre
Dernière intervention
26 juin 2020

bonjour, et merci pour votre réponse

je voudrais simplement copie le texte L & M en écrasant les formules sur B&C dans la même ligne mais en gardant les formules du dessous et dessus.

merci
Messages postés
9498
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
10 juillet 2020
1 858
Pourquoi ouvrir une nouvelle discussion, tu as la réponse ici
Messages postés
34
Date d'inscription
mardi 12 juin 2018
Statut
Membre
Dernière intervention
26 juin 2020

merci pour le model
j'ai mis le fichier complet, car j'ai du mal à adapter la macro avec mon fichier complet, peut-être avec le nouveau modèle je pourrais adapter les mois suivants avec le même principe.
encore une fois merci pour tout

https://www.cjoint.com/c/IErqgeTw5p0
Messages postés
673
Date d'inscription
mardi 27 septembre 2011
Statut
Membre
Dernière intervention
17 mai 2019
53
A mettre en B3 :
=SI(L3<>"";L3;SI($D3="";"";RECHERCHEV($D3;table!$A$1:$D$9;2;FAUX)))

A adapter pour colonne C

Cdt,
Messages postés
34
Date d'inscription
mardi 12 juin 2018
Statut
Membre
Dernière intervention
26 juin 2020

bonjour et merci
désolé je ne comprends pas la formule.
merci
Messages postés
9498
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
10 juillet 2020
1 858
tes données ne sont pas organisées comme sur le fichier exemple
Les valeurs en L4 et M4 sont dans la même ligne que les cellules renseignées de la ligne 4
es tu sur que tu veux écraser les formules qui sont en B4 et C4 ?
ou bien veux tu mettre L4 en B5 et M4 en C5 ?

idem sur toutes les autres lignes paires
Messages postés
34
Date d'inscription
mardi 12 juin 2018
Statut
Membre
Dernière intervention
26 juin 2020

bonjour, et bon Dimanche
Désole pour la réponse tardive le second fichier complet est exact,le premier est une erreur
oui je veux bien écraser les formules en B4 et C4 ainsi de suite.
merci
Messages postés
9498
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
10 juillet 2020
1 858
Voilà

https://mon-partage.fr/f/UcoNSN8f/

Cdlmnt
Messages postés
34
Date d'inscription
mardi 12 juin 2018
Statut
Membre
Dernière intervention
26 juin 2020

bonjour,
merci beaucoup
A+