Copier une valeur si 2 données sont égales [Résolu/Fermé]

Signaler
Messages postés
16
Date d'inscription
mardi 5 février 2019
Statut
Membre
Dernière intervention
4 mars 2020
-
Messages postés
16
Date d'inscription
mardi 5 février 2019
Statut
Membre
Dernière intervention
4 mars 2020
-
Bonjour

Voilà je vous remercie d'avance pour le coup de main éventuel.

Je souhaiterai créer une formule qui remplirait ces conditions.

Si la valeur dans la case A déterminé (ex : B43) est égale à une valeur dans la colonne B d'une autre onglet (l'onglet NUMEROTATION 2019) alors copier la valeur de la Colonne C de l'onglet NUMEROTATION 2019 sur la même ligne que la valeur correspondante.

Désolé difficile de clarifier mon idée.


=si.conditions(B43='NUMEROTATION 2019'!A:A;"NUMEROTATION 2019'!H:H")


Merci de votre aide encore

1 réponse

Bonjour,

Essaye avec :
=SIERREUR(RECHERCHEV(B43;'NUMEROTATION 2019'!B1:H1000;7;FAUX);"NON TROUVE")


Cordialement.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63714 internautes nous ont dit merci ce mois-ci

Messages postés
16
Date d'inscription
mardi 5 février 2019
Statut
Membre
Dernière intervention
4 mars 2020

LA Colonne AP
Messages postés
25161
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 juillet 2020
5 345
Bonjour
et pourtant l'ami girus (salut) a raison
en AF4 et pas en AP qui est vide (?)

=SI(C4="";"";SIERREUR(RECHERCHEV(C4;'NUMEROTATION 2019'!A:H;7;0);"non trouvé"))

toutefois il ne semble pas y avoir beaucoup de références de cette colonne C présentes dans la feuille de recherche
crdlmnt
Messages postés
16
Date d'inscription
mardi 5 février 2019
Statut
Membre
Dernière intervention
4 mars 2020

Merci de votre retour, et oui cela fonctionne le souci était de ma faute, la donnée avait été mal rentrée je vais modifier cela.
Par contre il me copie la donnée dans la colonne F ou G mais pas la valeur numérique dans la colonne H, comment dois je procéder ?
Messages postés
25161
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 juillet 2020
5 345
la formule que j'ai écrite cherche la valeur dans la colonne A vous ressort la valeur dans la colonne de la plage dont le N° est indiqué derrière l'adresse de la plage
soit dans celle de mon message: la 7° colonne de la plage A:H et donc la colonne G
soit vous chercher dans la colonne A pour ressortir H et donc pour avoir la colonne H remplacer le 7 par 8
=SI(C4="";"";SIERREUR(RECHERCHEV(C4;'NUMEROTATION 2019'!A:H;8;0);"non trouvé"))
soit vous cherchez dans la colonne B et donc la formule devient:
=SI(C4="";"";SIERREUR(RECHERCHEV(C4;'NUMEROTATION 2019'!B:H;7;0);"non trouvé"))

crdlmnt
Messages postés
16
Date d'inscription
mardi 5 février 2019
Statut
Membre
Dernière intervention
4 mars 2020

Avec beaucoup de retard mais merci encore pour votre aide, j'ai pu avancer sur mon projet et c’est grâce à vous merci :)