Excel: compter le nombre de numéros commençant par... [Résolu/Fermé]

Signaler
-
 IRudiq -
Bonjour à tous:

Dans le cadre de mon entreprise, je dois être capable d'identifier combien de clients nous appellent depuis leur portable ou leurs fixe.

Je me retrouve donc avec une collecte de données client sur Excel comprenant le numéro depuis lequel ils nous ont appelé et je dois maintenat les compter.

Seul problème: lorsque j'utilise la fonction "countif" (=countif(range des data;"336*")) j'obtiens continuellement 0 en valeur.

Sauriez-vous ce que je ne fais pas correctement?

Merci par avance pour votre aide et bonne journée à vous tous !

2 réponses

Messages postés
2091
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
1 juillet 2020
276
Bonjour

Pour comptabiliser tous les N° commençant par 336
=SI(GAUCHE(range des data;3)="336";NB(range des data)), à valider avec CTRL + SHIFT + ENTREE

A adapter pour les autres numéros.

Cdlt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 64582 internautes nous ont dit merci ce mois-ci

Bonjour Frenchie83,

Merci pour ta réponde rapide.
Je viens d'essayer avec cette fonction: =IF(LEFT('Data appels mois de Mars 2019'!G2:G407;3)="336";COUNT('Data appels mois de Mars 2019'!G2:G407))
en m'assurant de valider comme tu l'as précisé mais ils me donnent comme résultat "FALSE".

J'ai auparavant changé le format des nombre en passant de "numéro de téléphone" à "nombre" en me disant que le problème venait peut-être de là mais ça n'a rien changé du tout.
Bonjour,
J'imagine que vos numéros de téléphone sont en colonne a1:a500. Vous pourriez ajouter une colonne en B1avec la formule =gauche(a1;3) tirée sur toute la colonne, qui sortirait donc les 3 premiers chiffres.
Ensuite une formule =NB.SI(a1:a500;336)
Cordialement.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 64582 internautes nous ont dit merci ce mois-ci

Bonjour Victor-92,

Merci beaucoup pour votre aide, cette solution fonctionne effectivement.

Votre aide à sauvé une vie ! ;)

Bonne journée
Utilisateur anonyme
Votre boss est si méchant ?