Modifier l'affichage de la barre de navigation

Résolu
Bonjour
Je suis en train de basculer mon site construit en PHP-MySQL sur WordPress.
J'ai donc installé WordPress dans un répertoire nommé WP, et là j'ai fait une bêtise. Car lorsque je vais sur mon site, au lieu de monsite.fr s'affiche wp.monsite.fr, ce qui ne me convient pas.
J'ai lu qu'il était assez risqué de renommer le répertoire pour afficher autre chose que wp , et je n'ai pas trouvé comment masquer ce wp. et revenir à l'affichage d'origine monsite.fr.
Avez vous une solution?
merci

5 réponses

  1. Peut être tu devrais regarder pour faire de url rewriting dans ton htaccess...?
    0
    1. Merci SioGabx pour cette piste..
      0
  2. Bonjour
    si ton blog est fini et que tu n'a plus besoin de ton ancien site, tu peux déplacer les fichiers index.php et htaccess de wp à la racine de ton hébergement (donc à la place de l'ancien site) et laisser le reste dans le dossier wp. Tu trouveras un tuto détaillé sur cette page du codex de wordpress. Comme ton site est déjà dans son répertoire définitif, il faut suivre la partie intitulée Utilisation d'une Installation Préexistante dans un Sous-Répertoire

    ton blog sera alors accessible avec l'adresse monsite.fr

    0
    1. Bon, j'ai tout planté...J'ai réinstallé WP dans un nouveau répertoire (tourisme) et j'ai ce msg d'erreur sur les modifications de thèmes

      Warning: require(/customers/e/3/2/monsite.fr/httpd.www/tourisme/tourisme/blog-header.php): failed to open stream: No such file or directory in /customers/e/3/2/monsite.fr/httpd.www/tourisme/index.php on line 17 Fatal error: require(): Failed opening required '/customers/e/3/2/monsite.fr/httpd.www/tourisme/tourisme/blog-header.php' (include_path='.:/usr/share/php') in /customers/e/3/2/monsite.fr/httpd.www/tourisme/index.php on line 17

      J'en déduis que l'erreur est sur le fichier index! Mon fichier index :
      <?php
      /**
      • Front to the WordPress application. This file doesn't do anything, but loads
      • wp-blog-header.php which does and tells WordPress to load the theme.

      *
      • @package WordPress
      • /


      /**
      • Tells WordPress to load the WordPress theme and output it.

      *
      • @var bool
      • /

      define( 'WP_USE_THEMES', true );

      /** Loads the WordPress Environment and Template */
      require( dirname( __FILE__ ) . '/tourisme/blog-header.php' );

      Voyez vous dans vos habitudes où je fais une erreur...Je pense que tout est dans la syntaxe du require
      Merci
      0
      1. Utilise les balises <code> stp
        0
    2. Bon, j'ai tout planté...J'ai réinstallé WP dans un nouveau répertoire (tourisme) et j'ai ce msg d'erreur sur les modifications de thèmes

      Warning: require(/customers/e/3/2/monsite.fr/httpd.www/tourisme/tourisme/blog-header.php): failed to open stream: No such file or directory in /customers/e/3/2/monsite.fr/httpd.www/tourisme/index.php on line 17 Fatal error: require(): Failed opening required '/customers/e/3/2/monsite.fr/httpd.www/tourisme/tourisme/blog-header.php' (include_path='.:/usr/share/php') in /customers/e/3/2/monsite.fr/httpd.www/tourisme/index.php on line 17

      J'en déduis que l'erreur est sur le fichier index! Mon fichier index (entre balises
      ):
      <code>
      <?php
      /**
      Front to the WordPress application. This file doesn't do anything, but loads
      wp-blog-header.php which does and tells WordPress to load the theme.
      • @package WordPress //** Tells WordPress to load the WordPress theme and output it.* @var bool /define( 'WP_USE_THEMES', true );/** Loads the WordPress Environment and Template */require( dirname( __FILE__ ) . '/tourisme/blog-header.php' );


      Voyez vous dans vos habitudes où je fais une erreur...Je pense que tout est dans la syntaxe du require
      Merci
      0
      1. et mon .htacces que je n'ai pas modifié

        # BEGIN WordPress
        <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /tourisme/
        RewriteRule ^index\.php$ - [L]
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule . /tourisme/index.php [L]
        </IfModule>

        # END WordPress
        0
      2. Re-
        Tu pourrais tenter de mettre à la place de "dirname( __FILE__ ) . '/tourisme/blog-header.php" le chemin absolut vers "blog-header.php" donc un chemin qui commence par un "/" depuis la racine de ton site ?
        0
    3. OK Résolu...erreur dans le fichier index... désolé du dérangement
      0
      1. Quel était l'erreur ?
        0