2 formules différentes dans une même cellule [Résolu/Fermé]

Signaler
Messages postés
55
Date d'inscription
mercredi 6 décembre 2017
Statut
Membre
Dernière intervention
3 mars 2020
-
Messages postés
55
Date d'inscription
mercredi 6 décembre 2017
Statut
Membre
Dernière intervention
3 mars 2020
-
Bonjour,

J'ai un fichier dont je veux calculer un % et que je veux dire que si le résultat du % est de 0%, je voudrais que ça indique --- au lieu de 0%

3 réponses

Messages postés
9493
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
3 juillet 2020
1 851
Bonjour

Essaies ceci
=SI((B2-A2)/B2=0;"_";(B2-A2)/B2)

Cdlmnt
Messages postés
2664
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
30 juin 2020
676
Bonjour,

Comme ceci

=SI((B2-A2)/B2>0;(B2-A2)/B2;"---")

et si tu veux que la cellule reste vide

=SI((B2-A2)/B2>0;(B2-A2)/B2;"")

Cordialement
Messages postés
55
Date d'inscription
mercredi 6 décembre 2017
Statut
Membre
Dernière intervention
3 mars 2020

OK super et ça fonctionne très bien et comment pourrais-je ajouter une autre condition en disant que mes cellules a4 (ou a5) si elles ont rien d'entrées ou si elles sont à zéro de mettre une case vide dans la colonne C en plus de mes formules qui sont déjà là au lieu d'afficher #DIV/0! (Voir la photo de mon document ci-joint)

Merci beaucoup à l'avance :-)
Messages postés
2664
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
30 juin 2020
676 >
Messages postés
55
Date d'inscription
mercredi 6 décembre 2017
Statut
Membre
Dernière intervention
3 mars 2020

Bonjour,
Il suffit d'ajouter une condition à la formule

=SI(OU(A2="";B2="");"";SI((B2-A2)/B2=0;"---";(B2-A2)/B2))

Cordialement
Messages postés
55
Date d'inscription
mercredi 6 décembre 2017
Statut
Membre
Dernière intervention
3 mars 2020

Merci énormément, ça fonctionne super bien :-)
Messages postés
55
Date d'inscription
mercredi 6 décembre 2017
Statut
Membre
Dernière intervention
3 mars 2020

Merci beaucoup de votre aide :-)