Recherche de valeurs dans deux colonnes et auto remplissage [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
jeudi 7 mars 2019
Statut
Membre
Dernière intervention
8 mars 2019
-
Messages postés
4
Date d'inscription
jeudi 7 mars 2019
Statut
Membre
Dernière intervention
8 mars 2019
-
Bonjour,

j'ai un classeur avec une feuille par mois ("janvier", "février", etc) dans lesquelles j'entre quotidiennement les informations sur mes clients en visite (ce sont souvent les mêmes qui reviennent) :
"date" en colonne A, "nom" en colonne B, "prénom" en colonne C, "numéro de téléphone" en colonne E, etc

j'ai rajouté une feuille "liste" dans laquelle j'ai compilé ma liste de clients : "nom" en colonne A, "prénom" en colonne B et "numéro de téléphone" en colonne C.

Je recherche une fonction qui remplirait automatiquement les cellules de la colonne E des numéros de téléphone de mes tableaux mensuels par rapport aux noms et prénoms des clients que j'entre au fur et à mesure en A et en B, en allant les chercher dans ma liste de client.


Quelqu'un aurait-il une solution ?

Merci

2 réponses

Messages postés
5469
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
2 juillet 2020
453
Bonjour CyrilCharente

Essayer cette formule

=RECHERCHEV(A1;clients;3;0)
A1 = nom recherché
clients correspond à la table des noms prénoms et n°- téléphone
3 colonne ou se trouve les N°- téléphones dans la table clients

Ou
Celle-ci si vous avez plusieurs noms identiques

=RECHERCHEV(A5&" "&B5;clients;2;0)
la table clients n'a que 2 colonnes
A nom et prénom séparé par un espace
B n°- téléphone

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63753 internautes nous ont dit merci ce mois-ci

Messages postés
4
Date d'inscription
jeudi 7 mars 2019
Statut
Membre
Dernière intervention
8 mars 2019

Cela fonctionne

J'ai rajouté une colonne dans mon tableau et une colonne dans ma base client avec la formule =A5&" "&B5 afin d'avoir le nom et le prénom ensemble dans des cellules. La formule que vous m'avez montré ( =RECHERCHEV(A5&" "&B5;clients;2;0) ) peut donc s'appuyer sur ces colonnes et trouver le numéro de télephone à associer.
Il m'a ensuite suffit de masquer ces colonnes qui ne m'intéressaient pas pour garder mon tableau clair et le tour est joué.

Je vous remercie de votre aide
Messages postés
4
Date d'inscription
jeudi 7 mars 2019
Statut
Membre
Dernière intervention
8 mars 2019

Bon, vous avez résolu mon problème qui m'a permis d'en découvrir un autre : certains de mes clients m'ont donné des numéros de télephone différents lors de leurs passages, et ils se retrouvent donc sur plusieurs lignes de ma base, donc la formule ne s'applique pas pour eux (soit deux ou trois lignes avec le même nom et prénom mais pas le même téléphone dans ma base)
Quelqu'un aurait-il une idée pour que la formule ne prenne que le premier numéro, ou un des numéros au hasard?
Messages postés
5469
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
2 juillet 2020
453
mettre les numéros dans les colonnes suivantes (attention au nom de la table clients il doit englober toutes les colonnes)
Une seule ligne par client
si vous voulez un de ces numéros, il faut mettre le numéro de colonne correspondant
Messages postés
4
Date d'inscription
jeudi 7 mars 2019
Statut
Membre
Dernière intervention
8 mars 2019

Parfait merci

Bonjour,
Peut-être un tableau dans ce genre :
https://cjoint.com/c/IChlfON6fCh
Cordialement,
Arthur
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63753 internautes nous ont dit merci ce mois-ci