Date du dernier Mardi ou Jeudi pour le mois en cours [Résolu/Fermé]

Signaler
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020
-
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020
-
Bonjour,

Voila une formule qui donne le dernier Landi du mois, pour moi je suis en besoin de m'aider a trouver le dernier Mardi ou Jeudi le plus proche de la fin du mois, Merci infiniment:

exemple:
=DATE(ANNEE(A1);MOIS(A1)+1;0)-JOURSEM(DATE(ANNEE(A1);MOIS(A1)+1;0);3)


Configuration: Windows / Firefox 52.0

3 réponses

Messages postés
5469
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
2 juillet 2020
453
Bonjour nonossov

Essayer cette formule

Pour le mardi

=FIN.MOIS(A1;0)+CHOISIR(JOURSEM(FIN.MOIS($A$1;0);2);-6;0;-1;-2;-3;-4;-5)

Pour le jeudi

=FIN.MOIS(A1;0)+CHOISIR(JOURSEM(FIN.MOIS($A$1;0);2);-6;0;-1;-2;-3;-4;-5)

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63858 internautes nous ont dit merci ce mois-ci

Messages postés
5469
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
2 juillet 2020
453
Bonjour

Quand vous recevez nom
c'est une fonction qui n'est pas présente dans votre version Excel!
Vérifiez si vous avez toutes les fonctions de la formule
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63858 internautes nous ont dit merci ce mois-ci

Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

j'ai une version 2003, est ce qu'il ya possibilité pour qu'elle fonctionne sur 2003
Messages postés
5469
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
2 juillet 2020
453
Je ne sais pas, quelles fonctions n'avez vous pas ?
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

j'ai excel 2003 et j'ai essayé d'executer cette fromule =SI(JOURSEM(FIN.MOIS(A1;0);2)>=4;FIN.MOIS($A1;0)+CHOISIR(JOURSEM(FIN.MOIS($A1;0);2);0;0;0;0;-1;-2;-3);FIN.MOIS(A1;0)+CHOISIR(JOURSEM(FIN.MOIS($A1;0);2);-4;0;-1;0;0;0;0)) mais ne n'ai pas reussi
Messages postés
2334
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
30 juin 2020
849 >
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

Bonjour,
Avec 2003: Outils >> macros complémentaires >> cocher Utilitaire d'analyse. Sinon Fin.Mois() ne fonctionne pas.
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

Merci infiniment :)
Messages postés
5469
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
2 juillet 2020
453
Bonjour nonossov

Pour les 2 en même temps

=SI(JOURSEM(FIN.MOIS(A1;0);2)>=4;FIN.MOIS($A1;0)+CHOISIR(JOURSEM(FIN.MOIS($A1;0);2);0;0;0;0;-1;-2;-3);FIN.MOIS(A1;0)+CHOISIR(JOURSEM(FIN.MOIS($A1;0);2);-4;0;-1;0;0;0;0))
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020

je ne sais pas pourquoi la formule ne marche pas, je recois : #NOM?
??