Excel : comment intervertir 2 mots dans une même cellule [Fermé]

Signaler
Messages postés
158
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
25 mars 2021
-
Messages postés
26015
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
11 mai 2021
-
Bonsoir,

Je souhaite utiliser une recherchev à partir de 2 fichiers distincts mais dans l un j’ai une colonne avec une cellule composée de NOM et Prénom et dans la seconde colonne le Prénom et le NOM.
Est il possible avec une formule Excel d intervertir les 2 mots de la même cellule afin qu’elles soient à lidentiques dans les deux fichiers.
Merci beaucoup pour votre aide.
Zara70
A voir également:

2 réponses

Messages postés
1063
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
23 mars 2021
222
Bonsoir

Cela dépend surtout du formatage entre le nom et le prénom
si le nom est en majuscule et le ou les prénoms en nom propre, c'est faisable
sinon ???
Messages postés
158
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
25 mars 2021

Je ne comprends pas bien ce que vous voulez me dire
Messages postés
26015
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
11 mai 2021
5 920
Bon jour

essayez une formule de ce genre:
attention formule matricielle à entrer avec la touche enter en maintenant les touches ctrl et shift enfoncées
(et à limiter au nombre de lignes utiles, autant pour les adresses de champ que pour la recopie éventuelle, la formule étant gourmande en capacité)

exemple
ressortir de la feuil1 ligne 2 à ligne 1000 colonne C la valeur sur la ligne qui contient le prénom en A et le nom en B
la feuil 2 contient le nom en A et le prénom en B à partir de ligne2

en feuil2 C2:

=SIERREUR(INDEX(feuil1!$C$2:$C$1000;EQUIV(B2&A2;feuil1!$A$2:$A$1000&feuil1!$B$2:$B$1000;0));"non trouvé")

et pour complèter si vous ne savez pas dans quel sens sont nom et prénom à chercher, on peut compliquer un peu:
=SIERREUR(SIERREUR5INDEX(feuil1!$C$2:$C$1000;EQUIV(B2&A2;feuil1!$A$2:$A$1000&feuil1!$B$2:$B$1000;0));INDEX(feuil1!$C$2:$C$1000;EQUIV(A2&B2;feuil1!$A$2:$A$1000&feuil1!$B$2:$B$1000;0)));"non trouvé")

en inversant entre les deux item, A et B cherchés dans le code EQUIV

crdlmnt