[Filezilla] Echec connexion entre mes 2 PC [Résolu/Fermé]

Signaler
Messages postés
68
Date d'inscription
lundi 26 janvier 2009
Statut
Membre
Dernière intervention
29 octobre 2019
-
Messages postés
92027
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
2 juillet 2020
-
Bonjour,

J'ai 2 pc (1 windows 10 et 1 linux debian9) à la maison, je voudrais faire de l'échange de fichier, j'ai donc installé sur le W10 Filezilla serveur et sur Debian Filezilla client. J'avais dès le départ plein de problème sur les 2, mais à force de tripatouiller (et notamment de passer le server en passif) j'ai réussi à faire en sorte que le server fonctionne sans message d'erreurs. Le problème c'est que pour autant le client n'arrive pas à s'y connecter. Le message que ça me donne c'est "Connection interrompue après 20 secondes d'inactivité, Impossible d'établir une connexion au serveur". Les 2 pc se ping bien mutuellement, j'ai ouvert les ports 21, 990 et 14147 de ma box mais sans succès.

D'avance merci pour votre aide.


Configuration: Linux / Firefox 60.0

2 réponses

Messages postés
92027
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
2 juillet 2020
9 910
Salut,
les deux PC ne sont pas en local, tu en as un à l'extérieur ?
Messages postés
68
Date d'inscription
lundi 26 janvier 2009
Statut
Membre
Dernière intervention
29 octobre 2019
12
Si si, ils sont les 2 sur le même réseau.
Messages postés
92027
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
2 juillet 2020
9 910 >
Messages postés
68
Date d'inscription
lundi 26 janvier 2009
Statut
Membre
Dernière intervention
29 octobre 2019

Alors,
il ne sert à rien de passer la connexion serveur en passif.
tu n'as pas un parefeu à la con qui traine sur ce serveur, ou sur le client ...
Messages postés
68
Date d'inscription
lundi 26 janvier 2009
Statut
Membre
Dernière intervention
29 octobre 2019
12
Bon j'ai réussi à les faire communiquer. Par contre, sur mon pc Debian, j'ai aussi créé une machine virtuelle sur Virtualbox. C'est une Windows7, en NAT (10.0.2.X); elle a accès à internet et elle ping mon pc qui lui est en 192.168.1.X mais lui par contre ne la ping pas. J'aimerais aussi les faire communiquer.
Merci d'avance.
Messages postés
92027
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
2 juillet 2020
9 910
Alors, ne mets pas la carte réseau en nat, mais en bridge, elles pourront communiquer.
Messages postés
68
Date d'inscription
lundi 26 janvier 2009
Statut
Membre
Dernière intervention
29 octobre 2019
12 >
Messages postés
92027
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
2 juillet 2020

C'est fait, du coup W7 est passé en 192.168.1.X, a toujours accès à internet mais ne ping plus Debian (durée de vie TTL expirée lors du transit) alors que debian le ping.
Messages postés
92027
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
2 juillet 2020
9 910 >
Messages postés
68
Date d'inscription
lundi 26 janvier 2009
Statut
Membre
Dernière intervention
29 octobre 2019

Tu n'as pas configuré une route à la noix par hasard ?
essaie un traceroute (tracert) à la place de ping
Le Debian, c'est bien sa machine hôte ?
au fait,
c'est bien l'adresse ip en 192.168.1.x que tu pingue de la machine debian ?
parce que si tu pingue une 10.quetchose, ça ne va pas le faire, forcément, ça n'est plus ton réseau et la box ne sait pas le joindre.
Messages postés
68
Date d'inscription
lundi 26 janvier 2009
Statut
Membre
Dernière intervention
29 octobre 2019
12 >
Messages postés
92027
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
2 juillet 2020

ça y est ça fonctionne. J'avais juste fait une faute de frappe. merci!
Messages postés
92027
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
2 juillet 2020
9 910 >
Messages postés
68
Date d'inscription
lundi 26 janvier 2009
Statut
Membre
Dernière intervention
29 octobre 2019

ça n'aide pas en effet .... :-)