Activer un mot de passe/ pbe de lien

Résolu/Fermé
Signaler
Messages postés
150
Date d'inscription
vendredi 10 août 2007
Statut
Membre
Dernière intervention
23 avril 2010
-
 Georges6180 -
Bonjour,

Quand un user a perdu son mot de passe je lui en envoie un nouveau (généré aleatoirement ) avec un lien lui permettant d'activer son nouveau mot de passe via son adresse mail que j'ai stocké dans ma base de donnée.

La personne reçoit bien le mail avec son mot de passe et le lien Ok jusqu'ici tout va bien.

Le problème est que quand la personne clique sur le lien( via firefox sur windows), elle obtient le message suivant :
Connexion échoué : erreur de connexion firefox ne peut établir de connexion avec lme server a l'adresse localhost.

Mon lien est le suivant : <a href="http://localhost/apache2-default/form_identification.html"></a>

Je ne comprend pas mes script sont tous localisé dans /var/www/apache2-default.
Je suis sur linux, ubunutu, php5, apache2.

Peut-on me guider?

5 réponses

Bonjour,

C'est normal,LocalHost, c'est chez toi, ton user se trouve chez lui, sur SON pc, locaalHost chez lui c'est 127.0.01. Donc pour aller cher toi il doit taper http://TON ADRESSE/apache...etc. Même s'il est sur ton serveur, il est chez lui et, par exemple, le disque C: c'est chez lui et pas chez toi.

J'espère avoir été clair.
Bonne chance
Georges
0
Messages postés
150
Date d'inscription
vendredi 10 août 2007
Statut
Membre
Dernière intervention
23 avril 2010
2
Salut,

Oui je pense avoir compris.


Désormais mon lien est : <a href="http://127.0.0.1/apache2-default/form_identification.html"></a>
Néanmoins quand je clique j'ai toujours le même problème :firefox ne peut établir de connexion avec le server 127.0.0.1
0
Non, je veux dire l'adresse de ton serveur sur internet soit quelque chose du genre de 212.123.056.123.
127.0.0.1 = LocalHost

Les adresses 127.0.0.1 et localhost sont identiques et locales.
Je sais que c'est pas évident mais quand je dis mon adresse locale, je fais référence à quelque chose qui m'est propre, et mon adresse locale n'est pas la même que ton adresse locale, même si elle porte le même nom.
Quand tu dis mon carnet et mois je dis aussi mon carnet, il ne s'agit pas du même carnet, même chose pour LocalHost.

J'espère que tu me comprends.

Bon courage.
Georges
0
Messages postés
150
Date d'inscription
vendredi 10 août 2007
Statut
Membre
Dernière intervention
23 avril 2010
2
Ok.
j'ai trouvé l'adresse IP de mon server en tapant ipconfig dans windows.
Mais j'ai toujous le même type de message!
0
Attends, je n'y suis plus.

Tu as bien dit :

"La personne reçoit bien le mail avec son mot de passe et le lien Ok jusqu'ici tout va bien.
Le problème est que quand la personne clique sur le lien( via firefox sur windows), elle obtient le message suivant :..."

Donc, si je comprends bien, ton abonné, sur SON pc clique sur ton lien, ...
C'est bien ça?

Donc, ton abonné, client, user ou ... , ne peut retrouver son mot de passe?
C'est toujours bien ça?

Donc, dans ton lien, tu dois mettre l'adresse IP de ton serveur, et cela même quand tu fais des essais chez toi.

Je simplifie, tu dois donner l'adresse de ton site.

OK?

Georges
0