Moyenne Excel avec valeur =0

[Résolu/Fermé]
Signaler
Messages postés
6
Date d'inscription
mercredi 21 novembre 2018
Statut
Membre
Dernière intervention
21 novembre 2018
-
Messages postés
6
Date d'inscription
mercredi 21 novembre 2018
Statut
Membre
Dernière intervention
21 novembre 2018
-
Bonjour,


Je souhaite faire une moyenne où mes cellule ne son pas regrouper et ou certaine on actuellement une valeur égale à 0.
Dans la saisie que je fait la moyenne me prend en compte les cellule =0 et ainsi me fausse le résultat.


=MOYENNE(C13;C19;C25;C31;C37;C43;C49;C55;C61;C67;C73)

Merci pour aide

4 réponses

Messages postés
17603
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 octobre 2021
4 791
Bonjour,

le plus simple serait de rapatrier les montants dans des cellules contiguës, exemple en O2 =C13, en O3=C19 etc ...

à partir de la la formule est simple
=MOYENNE.SI(O2:O12;"<>0")

ou encore
=SOMME(C13;C19;C25;C31;C37;C43;C49;C55;C61;C67;C73)/(NB.SI(C13;">"&0)+NB.SI(C19;">"&0)+NB.SI(C25;">"&0)+NB.SI(C31;">"&0)+NB.SI(C37;">"&0)+NB.SI(C43;">"&0)+NB.SI(C49;">"&0)+NB.SI(C55;">"&0)+NB.SI(C61;">"&0)+NB.SI(C67;">"&0)+NB.SI(C73;">"&0))

en attendant je regarde en formule matricielle ce qui est possible de faire en plus court
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
6
Date d'inscription
mercredi 21 novembre 2018
Statut
Membre
Dernière intervention
21 novembre 2018

mike-31, les cellules dont je souhaite faire la moyenne sont issue de formaule. est ce que ça change qqch dans la saisie?
Messages postés
6
Date d'inscription
mercredi 21 novembre 2018
Statut
Membre
Dernière intervention
21 novembre 2018

En ts cas, merci pour celle si, elle fonctionne. ;)
Messages postés
17603
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 octobre 2021
4 791
Re,

que le contenu des cellules soit issu de formule ne change rien, le seul bémol est que si le résultat contient des décimales masquées exemple il est affiché 125,02 mais en fait le résultat est 125,02133 ces décimales ne sont pas ignorées par Excel ou il faut utiliser la syntaxe ARRONDI

as tu vu et testé les deux formules
Messages postés
6
Date d'inscription
mercredi 21 novembre 2018
Statut
Membre
Dernière intervention
21 novembre 2018

les décimales ne dérange pas.
J'ai fait la seconde. La première j'ai pas compris.
Messages postés
17603
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 octobre 2021
4 791
Re,

pour la première, il suffit de créer une liste continue de tes valeurs exemple en colonne O en O2 tu écris
=la première cellule soit =C13 puis en O3 =C19 puis en O4 =C25 en O5 =C31 et continuer pour les cellules C37;C43;C49;C55;C61;C67;C73

ce qui va rapatrier la valeur de toutes tes cellules C13;C19;C25;C31;C37;C43;C49;C55;C61;C67;C73 dans des cellules contiguës entre O2 et O12 puisque tu as 11 cellules concernées
et ta formule devient
=MOYENNE.SI(O2:O12;"<>0")
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
6
Date d'inscription
mercredi 21 novembre 2018
Statut
Membre
Dernière intervention
21 novembre 2018

ok j'ai compris.

Je te remercie
Messages postés
24205
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
6 937
Bonjour,

comme ce sont des formules si tu peux mettre "" à la place des 0 alors :
=moyenne(tes_cellules)

sera correct.
eric
Messages postés
6
Date d'inscription
mercredi 21 novembre 2018
Statut
Membre
Dernière intervention
21 novembre 2018

merci à tous pour vos réponse.