Compter nombre de cellules non vides d'une colonne

Résolu/Fermé
hernie55 Messages postés 22 Date d'inscription lundi 29 octobre 2018 Statut Membre Dernière intervention 17 décembre 2018 - 29 oct. 2018 à 13:35
hernie55 Messages postés 22 Date d'inscription lundi 29 octobre 2018 Statut Membre Dernière intervention 17 décembre 2018 - 29 oct. 2018 à 16:31
Bonjour,

Je m'arrache les cheveux sur une formule depuis ce matin. Si quelqu'un peut m'aider...
J'ai dans la colonne C des dates ou des cellules vides.
Dans la colonne B des noms de ville (LONDRES, BIRMINGHAM, WASHINGTON et NEW YORK).
Dans la colonne A j'ai des noms d'entreprises.
J'ai besoin de compter le nombre de dates de la colonne C en fonction des pays Donc combien d'entreprises anglaises ont participé à l'évènement dont la date est indiquée en C? Et combien d'entreprises américaines... ?
J'ai essayé avec sommeprod, Nbval, nb.si.ens mais pas moyen de trouver la bonne formule et la bonne syntaxe
Merci d'avance pour votre aide.
Bon après-midi.

5 réponses

via55 Messages postés 13966 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 30 novembre 2022 2 521
29 oct. 2018 à 13:51
Bonjour

=NB.SI.ENS(C:C<>"";B:B;"LONDRES") +NB.SI.ENS(C:C<>"";B:B;"BIRMINGHAM") donnera le nombre de dates dans ces 2 villes anglaises

Cdlmnt
Via
0
hernie55 Messages postés 22 Date d'inscription lundi 29 octobre 2018 Statut Membre Dernière intervention 17 décembre 2018
29 oct. 2018 à 16:03
Merci beaucoup pour cette réponse, en revanche cela ne fonctionne pas, Excel me dit qu'il a trouvé une erreur dans cette formule. Mais je ne sais pas laquelle. Il m'a fait ça toute la matinée
0
via55 Messages postés 13966 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 30 novembre 2022 2 521
29 oct. 2018 à 16:15
Désolé j'avais tapé un peu vite la formule !
la bonne :
=NB.SI.ENS(C:C;">0";B:B;"LONDRES") + NB.SI.ENS(C:C;">0";B:B;"BIRMINGHAM")
0
hernie55 Messages postés 22 Date d'inscription lundi 29 octobre 2018 Statut Membre Dernière intervention 17 décembre 2018
29 oct. 2018 à 16:15
Je viens d'essayer :

=NB.SI.ENS(C2:C66;"NON(ESTVIDE)";B2:B66;"LONDRES")+NB.SI.ENS(C2:C66;"NON(ESTVIDE)";B2:B66;"BIRMINGHAM")

Il me renvoie le résultat 0, ce qui n'est pas possible.
0
via55 Messages postés 13966 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 30 novembre 2022 2 521
29 oct. 2018 à 16:17
Il faut enlever les guillemets entourant les NON(ESTVIDE) mais la formule que je viens de te renvoyer fonctionne par contre
0
hernie55 Messages postés 22 Date d'inscription lundi 29 octobre 2018 Statut Membre Dernière intervention 17 décembre 2018
29 oct. 2018 à 16:21
Si je fais :

=NB.SI.ENS(C2:C66;"<>""";B2:B66;"LONDRES")+NB.SI.ENS(C2:C66;"<>""";B2:B66;"BIRMINGHAM")

Excel me renvoie bien un résultat mais pas celui que j'attends, il compte non pas le nombre de dates dans la colonne C mais le nombre de cellules de la colonne B intitule Londres et Birmingham.

Quelqu'un a une solution?

Merci d'avance
0
via55 Messages postés 13966 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 30 novembre 2022 2 521
29 oct. 2018 à 16:23
As tu essayé ma nouvelle formule du post 3 ? Elle ne prend biien en compte que les lignes avec une date
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
hernie55 Messages postés 22 Date d'inscription lundi 29 octobre 2018 Statut Membre Dernière intervention 17 décembre 2018
29 oct. 2018 à 16:31
Merci Via55, nos posts se sont croisés. Cette fois cela fonctionne ! Youpi ! Merci beaucoup !
0