Problème d'accès à une partition luks avec fstab

Résolu/Fermé
Signaler
-
 Henri77 -
Bonjour,

Ce message fait suite à celui-ci (qui date de mai 2017 !).

J'ai finalement réinstallé et chiffré ma machine, puis j'ai chiffré mon disque secondaire avec Luks.
Celui se déverrouillait avec mon mot de passe de session.

Depuis la mise à jour d'Ubuntu 16.04 vers 18.04, les lignes sont commentées dans
/etc/fstab
:

cat /etc/fstab

#/dev/sdb1 /media/hdd2/ ext4 rw,nosuid,nodev,relatime,data=ordered,x-gvfs-show 0 0
#/dev/mapper/luks-01689e12-a01e-4279-98fc-19635ff4aa75 /media/hdd2 ext4 rw,nosuid,nodev,relatime,data=ordered 0 0


Un
mount
manuel me renvoie une erreur :

mount -t ext4 /dev/mapper/luks-01689e12-a01e-4279-98fc-19635ff4aa75 /media/hdd2

mount: /media/hdd2 : le périphérique spécial /dev/mapper/luks-a6aebe6f-73a4-478e-a97c-03db90162ae2 n'existe pas.


J'ai cherché mon problème sur le web et trouvé des solutions.
Si je monte la partition manuellement, cela fonctionne :

cryptsetup luksOpen /dev/sdb1 test

Saisissez la phrase secrète pour /dev/sdb1 : ******************


mount /dev/mapper/test /media/hdd2
ls /media/hdd2

mes_donnees divers 


Par contre, je sèche un peu sur comment faire l'équivalent directement dans
/etc/fstab
, afin de pouvoir à nouveau déverrouiller mon disque à l'ouverture de ma session.

Si quelqu'un passe dans le coin,
Merci

6 réponses

Messages postés
30370
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
1 décembre 2021
7 236
Bonjour,

Peux-tu nous donner les UUIDs de tes partitions ?

ls -l /dev/mapper/test
ls -l /dev/disk/by-uuid


Bonne chance
Bonjour mamiemando,

Voila les résultats des deux commandes.

ls -l /dev/mapper/test
:
lrwxrwxrwx 1 root root 7 août  24 21:57 /dev/mapper/test -> ../dm-3


ls -l /dev/disk/by-uuid
me renvoie :
total 0
lrwxrwxrwx 1 root root 10 août 24 21:57 01689e12-a01e-4279-98fc-19635ff4aa75 -> ../../sdb1
lrwxrwxrwx 1 root root 10 août 24 21:57 6009b9df-f2d5-49ad-9948-3f67269ae91a -> ../../dm-3
lrwxrwxrwx 1 root root 10 août 24 21:55 6c72ac5a-30ac-472f-9308-74786ecbbcb1 -> ../../dm-2
lrwxrwxrwx 1 root root 10 août 24 21:55 a3350ed3-2148-47dd-9f45-2819a4da7797 -> ../../dm-1
lrwxrwxrwx 1 root root 10 août 24 21:55 b0a67878-0b74-4e03-871a-015f2a1a5934 -> ../../dm-0
lrwxrwxrwx 1 root root 10 août 24 21:55 f9032aae-ffa8-4cf9-9ab8-edd6004bc927 -> ../../sda1


lsblk -f
me renvoie :
sda
├─sda1         ext2                   f9032aae-ffa8-4cf9-9ab8-edd6004bc927   /boot
├─sda2                                                                       
└─sda5         LVM2_member            IcHoZH-f5ss-ksTT-GTpK-j8Pt-F8Ta-cTErkk 
  ├─ubuntu--vg-root
  │            ext4                   b0a67878-0b74-4e03-871a-015f2a1a5934   /
  └─ubuntu--vg-swap_1
               swap                   a3350ed3-2148-47dd-9f45-2819a4da7797   
    └─cryptswap1
               swap                   6c72ac5a-30ac-472f-9308-74786ecbbcb1   [SWAP]
sdb                                                                          
└─sdb1         crypto_LUKS            01689e12-a01e-4279-98fc-19635ff4aa75   
  └─test       ext4        Disk2_data 6009b9df-f2d5-49ad-9948-3f67269ae91a   


Il y a aussi le fichier
/etc/crypttab
:

cryptswap1 UUID=a3350ed3-2148-47dd-9f45-2819a4da7797 /dev/urandom swap,offset=1024,cipher=aes-xts-plain64
luks-a6aebe6f-73a4-478e-a97c-03db90162ae2 UUID=a6aebe6f-73a4-478e-a97c-03db90162ae2 /etc/luks-keys/luks-a6aebe6f-73a4-478e-a97c-03db90162ae2 nofail


J'ai bien essayé de changer les uuids dans
/etc/fstab
et
/etc/crypttab
, mais ça me renvoie toujours les mèmes erreurs

mount: /media/hdd2 : wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error.
mount: /media/hdd2 : le périphérique spécial /dev/mapper/luks-6009b9df-f2d5-49ad-9948-3f67269ae91a n'existe pas.


Je sèche
Messages postés
30370
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
1 décembre 2021
7 236
Bonjour,

Si je me réfère à cette réponse :


1) Commence par installer cryptsetup (normalement c'est déjà installé) :

sudo apt-get update
sudo apt-get install cryptsetup



2) Dans
/etc/crypttab
figure l'UUID de la partition chiffrée (dans ton cas
01689e12-a01e-4279-98fc-19635ff4aa75
) :
sdb1_crypt              UUID=01689e12-a01e-4279-98fc-19635ff4aa75   none        luks



3) Dans
/etc/fstab
figure l'UUID de la partition contenue dans le volume chiffré (dans ton cas
UUID=6009b9df-f2d5-49ad-9948-3f67269ae91a
) :
UUID=6009b9df-f2d5-49ad-9948-3f67269ae91a      /mnt/hdd      ext4    defaults,errors=remount-ro              0 1


Après avoir modifié
/etc/crypttab
, il semble falloir aussi lancer
sudo update-initramfs -u -k all
.

Bonne chance
Merci pour ton retour
Hélas pas mieux

mount: /media/hdd2 : impossible de trouver UUID=6009b9df-f2d5-49ad-9948-3f67269ae91a.


je vais chercher avec tes infos
Messages postés
30370
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
1 décembre 2021
7 236
Tu as dû faire une faire une faute de frappe, il faut que tu copies colles l'UUID associé à
/dev/disk/by-uuid/dm-3
.
Oui j'avais du mal copier mon uid, il y a du mieux,
il me demande maintenant ma passphrase au démarrage.
merci a toi pour ton implication
bonne continuation
Messages postés
30370
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
1 décembre 2021
7 236
Parfait, c'est bon signe ! Je présume que maintenant tu parviens à faire le mount jusqu'au bout ?

Il me demande maintenant ma passphrase au démarrage.

Note qu'il est possible de monter une partition chiffrée au démarrage, mais le chiffrement perd alors un peu de son intérêt.

Pense à basculer ton sujet en résolu la prochaine fois :-)

Bonne chance