Prendre en compte que les lignes avec cases pleine [Résolu/Fermé]

Signaler
Messages postés
71
Date d'inscription
samedi 2 octobre 2010
Statut
Membre
Dernière intervention
7 décembre 2018
-
Messages postés
71
Date d'inscription
samedi 2 octobre 2010
Statut
Membre
Dernière intervention
7 décembre 2018
-
Bonjour tout le monde, j'espère que vous allez bien.

J'ai un soucis avec une formule sur excel je vous explique

J'ai un tableau composé de plusieurs lignes avec parfois des cellules vides dans ces lignes. J'aimerais que si une cellule se retrouve = 0, elle ne soit pas prise en compte dans mon calcul. Pour exemple :
(Feuille nommée Tableau 2)
Colonne 1 | Colonne 2 |
1................| 0...........
17..............| 14........
0................|3.........

Ma formule : =SI(ET(Tableau2[Colonne 1]>0;Tableau2[Colonne 2]>0);SOMME((Tableau2[Colonne 1])-SOMME(Tableau2[Colonne 2]))/SOMME(Tableau2[Colonne 2]);"NULL")

Quelqu'un saurait où ça cloche svp?
(PS je ne peux pas faire à la main les calculs, j'ai plus de 600 lignes)

2 réponses

Messages postés
2445
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
6 mai 2021
1 104
Bonjour
Pas bien vu le résultat escompté
essayer
=SOMMEPROD(A2:A4;B2:B4)

ou
=SOMMEPROD(A2:A4;B2:B4)/SOMME.SI(B2:B4;">0";B2:B4)
Messages postés
71
Date d'inscription
samedi 2 octobre 2010
Statut
Membre
Dernière intervention
7 décembre 2018

j'ai essayé la somme.si le résultat est le même qu'un simple somme
Messages postés
71
Date d'inscription
samedi 2 octobre 2010
Statut
Membre
Dernière intervention
7 décembre 2018

Merci j'ai réussi avec une formule proche que je ne connaissais pas ! SOMME.SI.ENS
Messages postés
418
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
21 mai 2019
76
Bonjour,
Le résultat est souhaité ligne par ligne ?
Si oui pas besoin de la fonction somme :
=SI(ET([Colonne 1]>0;[Colonne 2]>0);(([Colonne 1])-([Colonne 2]))/([Colonne 2]);"NULL")
Messages postés
71
Date d'inscription
samedi 2 octobre 2010
Statut
Membre
Dernière intervention
7 décembre 2018

Bonjour, j'avais déjà essayé cette solution, mais le problème est que cette formule prend en compte les 0.

Je pense que mon soucis vient du si(et qui me renvoie juste "c'est bon la colonne ne vaut pas 0".
Messages postés
418
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
21 mai 2019
76
Peut-être pouvez-vous partager votre fichier en indiquant le résultat souhaité pour chaque ligne. Je ne pense pas avoir tout à fait compris ce qui pose problème ici.