Serie de chiffre sans doublons

Résolu/Fermé
thomas - Modifié le 12 août 2018 à 15:09
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
- 12 août 2018 à 19:44
bonjour,
je suis à la recherche d'un tableau ou d'une formule qui
me permettrait d'inscrire une série de chiffre et me
préviendrait en cas de doublon dans ma suite de chiffre sur la même ligne.
merci pour votre aide


1 réponse

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 273
12 août 2018 à 16:09
Bonjour

sélectionnez la ligne à traiter, pour l'exemple A1:Z1
Ruban / onglet ACCUEIL
icone Mise en forme conditionnelle / nouvelle règle
"utiliser une formule...."
entrez cette formule:
=NB.SI($A$1:$Z$1;A1)>1
format /formatez les cellules afficheront ce format quand elles contiendrons la même valeur

vous pouvez aussi interdire l'entrée de deux valeurs identiques:
sélectionnez A1:Z1
Ruban / Onglet DONNEES
icone Validation des données
"validation des données"
en haut choisissez "personnalisé"
en bas entrez cette formule:
=NB.SI($A$1:$Z$1;A1)<2
et Excel vous avertira si vous voulez entrer deux fois la même valeur

Dans les deux cas, attention à la position des $ dans les formules

crdlmnt

0
bonsoir,
c'est parfait c'est exactement ça,
merci beaucoup !
(selon vous cette formule fonctionnerait elle
sur numbers (mac) ?)
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 273
12 août 2018 à 19:44
aucune idée sur la question... faut essayer!
Crdlmnt
0