TCD, champs calculé [Résolu/Fermé]

Signaler
-
 omni -
Bonjour,
Merci pour toutes vos contributions qui aident, je pense, un grand nombre de personnes !

Voici ma question :
Dans un TCD, qui comprend une dizaine de colonnes (de champs donc), je souhaite ajouter un champ calculé qui "cherche" la première valeur non nulle parmi des colonnes déterminées.
il est possible de faire cette manipulation avec la fonction SI mais il y a 9 colonnes donc la formule est imbuvable :(

Voici une capture d'écran avec le TDC et la colonne de résultat que je souhaite avoir : https://ibb.co/gsmjuT

D'avance merci et bonne journée


2 réponses

Messages postés
23656
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
19 novembre 2020
6 479
Bonjour,

sur un forum excel un xls est plus utile qu'une image.
Pense aux fainéants qui n'ont pas envie de recréer ce que tu as chez toi.
eric
Voici le lien vers le fichier : https://cjoint.com/c/HGCmk2GSZdA

merci
Messages postés
23656
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
19 novembre 2020
6 479
en M3 :
=SI(C3="";"";INDEX(A3:L3;MIN(SI(D3:L3=0;99;COLONNE(D3:L3)))))

formule matricielle à valider avec shift+ctrl+entrée
et à tirer vers le bas
eric
Bonjour eriiic,

Je vous remercie pour cette formule qui fonctionne parfaitement.
En revanche, pensez-vous qu'il soit possible de l'intégrer au TCD ?

Merci
Messages postés
23656
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
19 novembre 2020
6 479
Je ne pense pas non.
Par acquis de conscience j'ai voulu jeter un oeil, mais le ruban TCD n'apparait pas lorsque je me met dessus (?!?)

Par contre il est possible d'ajouter un champ dans les données.
En BG2 :
=INDEX(A2:BF2;;MIN(SI((DROITE($N$1:$BF$1;5)="total")*(N2:BF2>0)=0;999;COLONNE(N2:BF2))))

matricielle également
eric
Ok, merci à nouveau