Formule pour les données les plus anciennes

[Résolu/Fermé]
Signaler
Messages postés
22
Date d'inscription
lundi 18 juin 2018
Statut
Membre
Dernière intervention
13 février 2019
-
Messages postés
22
Date d'inscription
lundi 18 juin 2018
Statut
Membre
Dernière intervention
13 février 2019
-
Bonjour,

Quel est le bon formule pour chercher les données les plus anciennes? Veuillez trouver en pièce jointe ma demande avec détails.

Merci d'avance de votre aide.

Cordialement





2 réponses

Messages postés
26234
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2021
6 089
Bonjour
essayez avec par exemple la liste des produits commençant en D2

=INDEX($B$2:$B$20;EQUIV($D$2&MIN(SI($A$2:$A$20=D2;$C$2:$C$20));$A$2:$A$20&C$2:$C$20;0))

attention: cette formule est matricielle et doit être entrée avec la touche enter en maintenant les touches ctrl et shift enfoncées
(elle s'affiche automatiquement entre accolades dans la barre de formule)

notez que cette formule est assez lourde, mieux vaut limiter les champs (ici de ligne 2 à 20) au nombre de lignes utiles du tableau
crdlmnt

Messages postés
22
Date d'inscription
lundi 18 juin 2018
Statut
Membre
Dernière intervention
13 février 2019

Bonjour,
C'est super!! Merci beaucoup de votre aide.
Par contre, Est-ce que vous pouvez rajouter quelques choses dans le formule pour que le coût le plus ancien s'affiche qu'une seule fois, par exemple, le coût pour le produit 1 s'affiche 1 fois 1€ pour 2008, vide pour les autres années?
Cordialement
Messages postés
26234
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2021
6 089
Re

je n'avais pas vu que vous vouliez la formule sur toute la hauteur du tableau

dans le cas où vous tirez la formule sur la hauteur du tableau
1°)si votre tableau est classé par années croissantes en colonne B, c'est encore plus simple de n'afficher que le premier montant en colonne C selon le code produit et la matricielle est inutile
écrivez simplement en D2:

=SI(NB.SI($A$2:A2;A2)=1;B2;"")

attention aux signes $ sur le 1° A2 et pas sur le second

la valeur de s'affichera en face de la 1° ligne contenant le nom du produit seulement

2°) si votre tableau n'est pas classé c'est un peu plus compliqué et il faut revenir à la matricielle:
en D2:

=SI(C2=MIN(SI($A$2:$A$200=A2;$C$2:$C$20));B2;"")avec enter +ctrl+shift

qui n'affichera le résultat qu'en face de la 1° année

crdlmnt

Messages postés
22
Date d'inscription
lundi 18 juin 2018
Statut
Membre
Dernière intervention
13 février 2019

c'est génial!! Merci beaucoup.
je mets cette demande en tant que "résolu".
bon weekend à vous.