Moyenne en fonction de 2 élément

[Fermé]
Signaler
Messages postés
2
Date d'inscription
mercredi 30 mai 2018
Statut
Membre
Dernière intervention
30 mai 2018
-
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
-
Bonjour,

j'ai un souci. J'aimerais que excel fasse une moyenne en fonction d'une date de début et une date de fin Ex:

période 2010 2016

2008 2009 2010 2011 2012 2013 2014 2015 2016
1,2 1,6 1,5 1,1 1 0,9 0,5 0,6 2


moyenne 1,085714286

si je modifie la période j'aimerais que tous seul il fasse le calcule.

2 réponses

Messages postés
10151
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
18 octobre 2021
2 230
Bonjour

Une solution
https://www.cjoint.com/c/HEEriVeTIFB

Cdlmnt
Messages postés
2
Date d'inscription
mercredi 30 mai 2018
Statut
Membre
Dernière intervention
30 mai 2018

merci beaucoup
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 531
Bonjour,

Une formule différente de celle de ccm81 que je salue, avec DECALER
=SIERREUR(MOYENNE(DECALER($A$2;0;EQUIV(K2;A1:I1;0)-1;1;EQUIV(L2;A1:I1;0)-EQUIV(K2;A1:I1;0)+1));"param")

Avec le classeur test : https://www.cjoint.com/c/HEEs7i0oMFl