Formule à conditions [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
jeudi 3 mai 2018
Statut
Membre
Dernière intervention
3 mai 2018
-
Messages postés
2154
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
21 octobre 2020
-
Bonjour,

Je suis à la recherche d'une aide.
J'ai besoin décrire une formule à 3 condition (minimum) afin de rajouter des zéro devant certain codes.
Par exemple, si mon premier code est à 4 chiffres --> ne pas rajouter de zéro (ex :1003)/si le code est à 3 chiffres -->ajouter 1zéro devant (ex : 0244)/ si le code est à deux chiffre --> ajouter deux 0 devant (0015)/ si le code est à 1 chiffre -->ajouter 3 zéro devant (ex: 0005).
J'ai tenté plusieurs formules qui ne fonctionne pas.

Merci beaucoup par avance pour votre aide.

2 réponses

Messages postés
52511
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 octobre 2020
14 369
Bonjour.

C'est parfaitement inutile de créer une formule.
Il te suffit de sélectionner tes nombres et de faire :
Format de cellule/Nombre/Personnalisée puis de taper 0000 dans la fenêtre "Type".

Cordialement.
Messages postés
3
Date d'inscription
jeudi 3 mai 2018
Statut
Membre
Dernière intervention
3 mai 2018

Merci de votre réponse,

Enfaite, je pensais utiliser une formule pour automatiser ce traitement car je dois faire ce travail sur plus de 5000 lignes.

Cordialement
Messages postés
52511
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 octobre 2020
14 369
Justement : Il est bien plus facile d'appliquer un format sur 10 000 lignes que d'écrire 10 000 formules ! Cela se fait en une seule opération ...
Messages postés
3
Date d'inscription
jeudi 3 mai 2018
Statut
Membre
Dernière intervention
3 mai 2018

Merci de votre aide, j'ai réussis.
Messages postés
2154
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
21 octobre 2020
862
Bonsoir
si lucentA préfère une formule, une proposition
=SI(NBCAR(A2)=1;"000"&A2;SI(NBCAR(A2)=2;"00"&A2;SI(NBCAR(A2)=3;"0"&A2;A2)))