Fonction excel

Résolu/Fermé
Fabource Messages postés 20 Date d'inscription jeudi 19 mai 2016 Statut Membre Dernière intervention 25 septembre 2018 - Modifié le 20 avril 2018 à 08:46
Fabource Messages postés 20 Date d'inscription jeudi 19 mai 2016 Statut Membre Dernière intervention 25 septembre 2018 - 30 avril 2018 à 09:57
Bonjour,
Bonjour,
Dans la case A1,, je peux entrer 3 choses différentes : -MANUEL ; -DSA1235 . -152636
Dans la case A2, je peux entrer 100% ou la date
dans la case A3, je voudrais que ça affiche "VRAI" si A1 contient "MANUEL" ou "DSA" mais également, si A3 contient 100%
Vous pouvez m'aider?
Merci par avance



5 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 275
20 avril 2018 à 07:53
Bonjour

edit .".également si A3 contient 100%"????

on suppose que de A2 que vous parlez!

=SI(ET(A2=100%;OU( NB.SI(A1;"*MANUEL*");NB.SI(A2:"*DSA*"));VRAI;FAUX)

attention à tous les signes

crdlmnt
0
Fabource Messages postés 20 Date d'inscription jeudi 19 mai 2016 Statut Membre Dernière intervention 25 septembre 2018
20 avril 2018 à 08:30
Bonjour Vaucluse,
effectivement, il faut lire A2 à la place de A3.
La formule ne fonctionne pas. Entre A2 et "*DSA*", je me suis permis de mettre un ; à la place de ton :.
Mais ça ne fonctionne pas quand même.
Le message d'erreur me dit qu'il manque une parenthèse.
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 275
Modifié le 20 avril 2018 à 08:47
"Le message d'erreur me dit qu'il manque une parenthèse."
... et il a raison le bougre...suis mal réveillé ce matin.
la parenthèse à rajouter c'est derrière "*DSA*")))
_une pour le NB.SI, une pour le ET, une pour le OU
excuses
crdlmnt
0
Fabource Messages postés 20 Date d'inscription jeudi 19 mai 2016 Statut Membre Dernière intervention 25 septembre 2018
20 avril 2018 à 09:04
Euh ça ne fonctionne pas non plus.
Il n'y a plus d'erreur dans la formule, mais je n'ai pas le résultat escompté.
En A3, il affiche toujours FAUX, même si A1 et / ou A2 sont vides.
0
Fabource Messages postés 20 Date d'inscription jeudi 19 mai 2016 Statut Membre Dernière intervention 25 septembre 2018
20 avril 2018 à 09:07
Je précise toutefois que en A3, il n'y aura 100% que si A1 est un nombre.
Si en A1 il y a MANUEL ou DSA, en A3, il n'y aura jamais 100%
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 275
20 avril 2018 à 10:44
=SI(ET(A2=100%;OU( NB.SI(A1;"*MANUEL*");NB.SI(A1:"*DSA*")));VRAI;FAUX)

cette formule (corrigée complètement cette fois)

renvoie VRAI si à la fois:
  • A1 contient MANUEL ou DSA ( présent même au milieu d'un texte) *A2 contient 100%


si ce n'est pas ce que vous voulez, expliquez vous mieux, car dans votre dernier message, il y a des 100% en A3 on ne parle plus de A2

alors que viennent faire ces 100% en A3, là où, initialement vous vouliez VRAI ou FAUX???
0
Fabource Messages postés 20 Date d'inscription jeudi 19 mai 2016 Statut Membre Dernière intervention 25 septembre 2018
20 avril 2018 à 11:03
en A1, je peux mettre "MANUEL" ou "DSA"
en A2, je peux mettre "100%"
en A3, doit s'afficher VRAI ou FAUX si "MANUEL" ou "DSA" en A1 OU si "100%" en A2
Désolé pour les messages précédents peu clairs et un peu embrouillés.
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 275
20 avril 2018 à 11:35
pensez vous que ce soit mieux ici?

"en A3, doit s'afficher VRAI ou FAUX si "MANUEL" ou "DSA" en A1 OU si "100%" en A2 "

VRAI ou FAUX, oui, mais quand ??????

A1=MANUEL et A 2=100% ???
A1=DSA et A2=100% ????
A1= MANUEL OU DSA et A2<>100% ????
A1<>MANUEL ou DSA et A2 =100% ????

de plus vous dites dans votre 1° message que vous pouvez avoir en A1 des cihsies du type DS1235, d'où ma proposition avec NB.SI(A1;"*DSA*") pourb détecter si la cellule ciontient ou non les trois lettres quelues part

Alors confirmer et, en reprenant la iste ci dessu dites ce que vous voulez voir
0
Fabource Messages postés 20 Date d'inscription jeudi 19 mai 2016 Statut Membre Dernière intervention 25 septembre 2018
20 avril 2018 à 12:00
Si A1 contient MANUEL alors A3=VRAI
Si A1 contient DSA alors A3=VRAI
Si A2 = 100% alors A3=VRAI
Si 100% est en A2, il n'y aura ni DSA ni MANUEL en A1
S'il y a MANUEL ou DSA en A1, il n'y aura jamais 100% en A2
0
Merci Vaucluse.
Je ne peux plus essayer ça aujourd'hui mais je le fais des que possible et vous tiendrai au courant.
Merci mille fois pour votre patiene.
Excellente journée et week end à vous.
Encore merci.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Fabource Messages postés 20 Date d'inscription jeudi 19 mai 2016 Statut Membre Dernière intervention 25 septembre 2018
30 avril 2018 à 09:57
Bonjour Vaucluse.
Eh bien voilà, formule essayée, formule adoptée. Ça fonctionne parfaitement.
Merci beaucoup
Belle journée.
0