Si jours ouvrables ou pas

Résolu/Fermé
albertyx
Messages postés
51
Date d'inscription
vendredi 15 août 2008
Statut
Membre
Dernière intervention
21 janvier 2022
- 9 avril 2018 à 14:42
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
- 11 avril 2018 à 15:15
Bonjour à tous,

Je souhaite, si possible, avoir une fonction qui vérifie une case ak5, dans laquelle il y a une date. Si la date indiqué donne un jour ouvrable, Excel doit afficher le chiffre 0, si c'est un week-end ou jour férié dans la case ak5 Excel affiche un 1.

Merci beaucoup.



2 réponses

albertyx
Messages postés
51
Date d'inscription
vendredi 15 août 2008
Statut
Membre
Dernière intervention
21 janvier 2022
1
11 avril 2018 à 13:32
Bonjour,

Si je peux faire ça mais le document est vraiment très chargé c'est pour ça que je cherchais une solution mois lourde. Pratiquement, comment peut-on indiquer les fériés et week-ends dans ce document ? Y a-t-il une méthode spécifique ?
Merci.
1
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 273
Modifié le 11 avril 2018 à 14:38
La formule ne demande pas de lister les WE mais juste les jours fériés, soit 11 dates à placer dans une feuille vierge par exemple de A1 à A11 ou ailleurs, dans un coin disponible de n'importe quelle feuille.
(si vous voulez couvrir plusieurs années, ce n'est pas une montagne non plus, allongez la liste.
Vous pouvez placer dans la liste des JF même s'ils sont jours non ouvrables (samedi ou dimanche) Excel ne les décomptera qu'une fois
et ensuite la formule s'occupe toute seule des WE:
=SI(NB.JOURS.OUVRES(A1;A1;Feuilxx!$A$1:$A$11);0;1)
si votre liste est en feuilxx
vous pouvez aussi nommer ce champ par exemple jf, la formule devient:
=SI(NB.JOURS.OUVRES(A1;A1;jf);0;1)
crdlmnt
0
albertyx
Messages postés
51
Date d'inscription
vendredi 15 août 2008
Statut
Membre
Dernière intervention
21 janvier 2022
1
11 avril 2018 à 15:12
Merci beaucoup. Excellent !
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 273
Modifié le 11 avril 2018 à 15:15
Pas de quoi merci surtout à didibonf
je passe le sujet en résolu

bonne route
crdlmnt
0