Formule SI imbriqué avec fonctions Index Equiv [Résolu/Fermé]

Signaler
Messages postés
28
Date d'inscription
vendredi 6 avril 2018
Statut
Membre
Dernière intervention
31 octobre 2019
-
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
-
Bonjour,

Je cherche à imbriquer 3 fonctions SI avec les fonctions INDEX EQUIV comme s’ensuit :

=SI(Q2="4";(INDEX('GA300'!$1:$1048576;EQUIV(P2;'GA300'!$A:$A;0)+3;EQUIV($R$1;'GA300'!$1:$1;0)));0);
=SI(Q2="3";(INDEX('GA300'!$1:$1048576;EQUIV(P2;'GA300'!$A:$A;0)+2;EQUIV($R$1;'GA300'!$1:$1;0)));0);
=SI(Q2="2";(INDEX('GA300'!$1:$1048576;EQUIV(P2;'GA300'!$A:$A;0)+1;EQUIV($R$1;'GA300'!$1:$1;0)));0)

Pourriez-vous me donner la bonne formulation?

Merci par avance

1 réponse

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 070
Bonjour,

Comme ceci tu devrais avoir satisfaction :
=SI(ET(Q2>=2;Q2<=4);(INDEX('GA300'!$1:$1048576;EQUIV(P2;'GA300'!$A:$A;0)+Q2-1;EQUIV($R$1;'GA300'!$1:$1;0)));0)