A la recherche d'une formule excel

Résolu/Fermé
Signaler
Messages postés
3
Date d'inscription
jeudi 29 mars 2018
Statut
Membre
Dernière intervention
29 mars 2018
-
Messages postés
26305
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 décembre 2021
-
Bonjour à tous,

Je sollicite votre aide et votre savoir.
Je suis a la recherche d'une formule de calcul excel.
Je vous explique :
onglet 1 = mon tableau de bord
onglet 2 = le CA 2018 par magasin que j'alimenterais tous les mois
onglet 3 = le CA 2017 par magasin

J'ai utilisé une recherche v pour coller le CA 2018 dans mon tdb mais pour le CA 2017 c'est plus compliqué.
Si Mois = 2 (février) je dois retrouver la CA 2017 par magasin et la formule doit prendre le chiffre de janvier et févier (mois cumulés)
Idem pour Mars,(janvier + février+ mars)
Mon fichier fait 400 ligneset j'ai testé une recherche v + somme mais je ne sais pas si ça éxiste.
Merci à tous pour votre aide.
Bonne journée

4 réponses

Messages postés
26305
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 décembre 2021
6 131
Bonjour

sans savoir ce que vous avez comme données, difficile de vous proposer une option, on peut juste tenter une solution à adapter:
dans la base feuil1!
  • en colonne A les dates (jj/mm/aa)
  • en colonne B les noms de magasin
  • en colonne C les montants
  • tout ça de ligne 2 à ligne 400


dans l'édition feuil2!

de A2 à A12 la liste des dates du 1° jour du mois cherché (ou de n'importe lequel)
de B2 à B10, les noms des magasins

la formule en B2:
=SOMMEPROD((MOIS(Feuil1$A$2:$A$100<=MOIS($A2))*(Feuil1!$B$2:$B$100=$B2)*(Feuil!1$C$2:$C$100))

vous donnera le cumul selon magasin en B, de toutes les dates antérieures ou égales.

si jamais votre tableau feuil1 a en A des N° de mois plutôt que des dates, remplacez pour la ligne janvier l'item:
=SOMMEPROD((MOIS(Feuil1$A$2:$A$100<=MOIS($A2))*(.....
par
=SOMMEPROD((Feuil1$A$2:$A$100<=LIGNE(A1))*(.....

si vous en voulez plus il faudra nous donner plus d'info, ou soumettre un fichier (même en bidonnant les infos ici):
http://mon-partage.fr
en revenant coller le lien créé sur le site

crdlmnt
Messages postés
13206
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
1 décembre 2021
2 289
Bonjour

C'est un SOMME.SI.ENS qu'il te faut utiliser :
=SOMME.SI.ENS(plage à sommer;plage des dates;"<01/03/17") par exemple pour avoir la somme de janvier et février 2017

Difficile d'en dire plus sans connaître ton fichier
Exemple de ton fichier à poster sur cjoint.com, faire créer un lien, le copier et revenir le coller ici

Cdlmnt
Via

Messages postés
3
Date d'inscription
jeudi 29 mars 2018
Statut
Membre
Dernière intervention
29 mars 2018

Bonsoir à vous et merci pour vos réponses.

Voici le lien ou se trouve le fichier.
https://mon-partage.fr/f/OH9mXN5W/

Je vais essayer d'être claire dans ma demande.
Selon le Mois en C3(1 pour janvier) et le code Pdv (A6), D6 doit récupérer (dans l'onglet CA 2017) H3 pour janvier,
Si Mois 2 (février) et le code Pdv (A6), D6 doit récupérer (dans l'onglet CA 2017) H3+I3 pour février........ etc...
Sachant que c'est cette base qui alimentera les 50 onglets à venir
Merci encore pour votre aide et bonne fin de journée
Nath
Messages postés
26305
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 décembre 2021
6 131
Re

voyez ici, après quelques modifications citées ci dessous:
en feuille TDB C1 un menu déroulant pour placer la date du 1° jour du mois cherché
en feuille CA 2017
de T2 à AE2, les titres de colonnes sont remplacées par le 1° jour du mois, l'affichage est formaté en personnalisé et aaaa mmmm pour ressembler à votre modèle
mais tout permettre de travailler directement sur les valeurs des dates plutôt que sur des textes, c'est plus léger en formule

mais il y a moyen si vous voulez passer absolument par vos titres, ça va simplement être plus lourd!

quant à la formule, je crois que c'est ce que vous demandiez, elle fait la somme pour chaque magasin des montants depuis janvier 2017 colonne T de CA 2017, jusqu'à celle du mois affiché en C1

Revenez si ça ne convient pas, mais pour simplifier vos différents calculs à venir, je vous conseille d'utiliser la méthode de date de cette proposition

https://mon-partage.fr/f/r1GEDT0J/


en complément deux formules pour remplir automatiquement C2 et C3:

en C2: =MOIS(C1)

en C3 =ARRONDI.SUP(MOIS(C1)/3;0)

crdlmnt

Messages postés
3
Date d'inscription
jeudi 29 mars 2018
Statut
Membre
Dernière intervention
29 mars 2018

Hello Vaucluse,

Merci beaucoup, c'est exactement ça !!!!! :)

Merci encore et bonne soirée

Nath
Messages postés
26305
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 décembre 2021
6 131
Alors si ça convient, merci de passer le sujet en résolu
(menu roue dentée à droite du titre en haut du fil)
bonne route
crdlmnt